Auto Upload Images Settings setting-page.php cross-site request forgery
A vulnerability was found in Auto Upload Images up to 3.3.0 and classified as problematic. Affected by this issue is some unknown functionality of the file src/setting-page.php of the component Settings Handler. The manipulation leads to cross-site request forgery. The attack may be launched remotely. Upgrading to version 3.3.1 is able to address this issue. The name of the patch is 895770ee93887ec78429c78ffdfb865bee6f9436. It is recommended to upgrade the affected component. VDB-216482 is the identifier assigned to this vulnerability.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-4633
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 7 Nov 2026, 19:25 UTC · Revision 1
Source evidence
Auto Upload Images Settings setting-page.php cross-site request forgery
core-osv · Original sourcePublished 21 Dec 2022, 00:00 UTC
A vulnerability was found in Auto Upload Images up to 3.3.0 and classified as problematic. Affected by this issue is some unknown functionality of the file src/setting-page.php of the component Settings Handler. The manipulation leads to cross-site request forgery. The attack may be launched remotely. Upgrading to version 3.3.1 is able to address this issue. The name of the patch is 895770ee93887ec78429c78ffdfb865bee6f9436. It is recommended to upgrade the affected component. VDB-216482 is the identifier assigned to this vulnerability.
osv:CVE-2022-4633
Complete source record
{
"id": "558ffa2d14c0df0ac91cf96e8657788c19cce2b922be06fac52b1cb1ab68dace",
"url": "https://osv.dev/vulnerability/CVE-2022-4633",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Auto Upload Images Settings setting-page.php cross-site request forgery",
"summary": "A vulnerability was found in Auto Upload Images up to 3.3.0 and classified as problematic. Affected by this issue is some unknown functionality of the file src/setting-page.php of the component Settings Handler. The manipulation leads to cross-site request forgery. The attack may be launched remotely. Upgrading to version 3.3.1 is able to address this issue. The name of the patch is 895770ee93887ec78429c78ffdfb865bee6f9436. It is recommended to upgrade the affected component. VDB-216482 is the identifier assigned to this vulnerability.",
"evidence": "osv:CVE-2022-4633",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2022-4633",
"aliases": [
"CVE-2022-4633"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/airani/wp-auto-upload",
"type": "GIT",
"events": [
{
"introduced": "4555eba876f22e61ff47da34e22961cdf46d3e2d"
},
{
"fixed": "895770ee93887ec78429c78ffdfb865bee6f9436"
},
{
"fixed": "9360269757d0cb0caffdd85b723d4604ff8be9d6"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "3.0"
},
{
"last_affected": "3.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"introduced": "3.1"
},
{
"last_affected": "3.1"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"introduced": "3.2"
},
{
"last_affected": "3.2"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"introduced": "3.3"
},
{
"last_affected": "3.3"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"fixed": "895770ee93887ec78429c78ffdfb865bee6f9436"
}
],
"source": "REFERENCES_COMMIT"
},
{
"range": [
{
"fixed": "9360269757d0cb0caffdd85b723d4604ff8be9d6"
}
],
"source": "REFERENCES_TAG",
"original_tag": "v3.3.1"
}
]
}
}
],
"versions": [
"3.0",
"3.1",
"3.2",
"3.3",
"v3.3",
"v3.2.2",
"v3.2.1",
"v3.2",
"v3.0.1",
"v3.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-4633.json"
}
}
],
"modified": "2026-10-28T02:30:51.582089729Z",
"provider": "osv",
"references": [
"https://github.com/airani/wp-auto-upload/releases/tag/v3.3.1",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/4xxx/CVE-2022-4633.json",
"https://nvd.nist.gov/vuln/detail/CVE-2022-4633",
"https://vuldb.com/?id.216482",
"https://github.com/airani/wp-auto-upload/commit/895770ee93887ec78429c78ffdfb865bee6f9436"
],
"provider_metadata": {
"cwe_ids": [
"CWE-352"
],
"cna_assigner": "VulDB",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/4xxx/CVE-2022-4633.json"
}
},
"related_cves": [
{
"value": "CVE-2022-4633",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 520217,
"published_at": "2022-12-21T00:00:00+00:00"
}