High
Security advisory
phpMyAdmin 4.7.x and 4.8.x versions prior to 4.8.4 are affected by a series of CSRF flaws. By deceiving a user into clicking on a crafted URL, it is possible to perform harmful SQL operations such as renaming databases, creating new tables/routines, deleting designer pages, adding/deleting users, updating user passwords, killing SQL processes, etc.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2018-19969
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 06:06 UTC · Revision 1
Source evidence
phpMyAdmin 4.7.x and 4.8.x versions prior to 4.8.4 are affected by a series of CSRF flaws. By deceiving a user into clicking on a crafted URL, it is possible to perform harmful SQL operations such as renaming databases, creating new tables/routines, deleting designer pages, adding/deleting users, updating user passwords, killing SQL processes, etc.
osv:CVE-2018-19969
Complete source record
{
"id": "1a0f38337072f66b417f5ce0bf849efefda5f6887b87957c21bf0c7885d1adbf",
"url": "https://osv.dev/vulnerability/CVE-2018-19969",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2018-19969",
"summary": "phpMyAdmin 4.7.x and 4.8.x versions prior to 4.8.4 are affected by a series of CSRF flaws. By deceiving a user into clicking on a crafted URL, it is possible to perform harmful SQL operations such as renaming databases, creating new tables/routines, deleting designer pages, adding/deleting users, updating user passwords, killing SQL processes, etc.",
"evidence": "osv:CVE-2018-19969",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2018-19969",
"aliases": [
"CVE-2018-19969",
"GHSA-xwf2-53mc-r8hx"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/phpmyadmin/phpmyadmin",
"type": "GIT",
"events": [
{
"introduced": "5538c22c142fb735fb0a3f7b5dd5c9f016f0709a"
},
{
"last_affected": "466695b29f92c5d48dea215929213148d978e72f"
},
{
"introduced": "9d6ac04ae8cd7064c28c93a6a949cb5324899593"
},
{
"fixed": "56ba19808f020fa8ac63366d450c3928564a91b8"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:phpmyadmin:phpmyadmin:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "4.7.0"
},
{
"last_affected": "4.7.6"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:phpmyadmin:phpmyadmin:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "4.8.0"
},
{
"fixed": "4.8.4"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"RELEASE_4_7_6",
"RELEASE_4_7_0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2018-19969.json"
}
}
],
"modified": "2026-10-24T10:30:35.617286112Z",
"provider": "osv",
"references": [
"https://security.gentoo.org/glsa/201904-16",
"https://www.phpmyadmin.net/security/PMASA-2018-7/"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2018-19969",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 433777,
"published_at": "2018-12-11T17:29:00.273+00:00"
}