High
Security advisory
Arbitrary file upload in the Modern Events Calendar Lite WordPress plugin, versions before 5.16.5, did not properly check the imported file, allowing PHP ones to be uploaded by administrator by using the 'text/csv' content-type in the request.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2021-24145
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 07:57 UTC · Revision 1
Source evidence
Arbitrary file upload in the Modern Events Calendar Lite WordPress plugin, versions before 5.16.5, did not properly check the imported file, allowing PHP ones to be uploaded by administrator by using the 'text/csv' content-type in the request.
osv:CVE-2021-24145
Complete source record
{
"id": "ad8022fdbce22689f396ba2a4312dbd361b23aa7e130ab122c8635637eff80a1",
"url": "https://osv.dev/vulnerability/CVE-2021-24145",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2021-24145",
"summary": "Arbitrary file upload in the Modern Events Calendar Lite WordPress plugin, versions before 5.16.5, did not properly check the imported file, allowing PHP ones to be uploaded by administrator by using the 'text/csv' content-type in the request.",
"evidence": "osv:CVE-2021-24145",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2021-24145",
"aliases": [
"CVE-2021-24145"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/webnuswp/modern-events-calendar-lite",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "2cf923ae6ac8957825b179a850fc8e41fac98bc9"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:webnus:modern_events_calendar_lite:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "5.16.5"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"5.16.2",
"5.16.1",
"5.16.0",
"5.15.5",
"5.15.0",
"5.14.0",
"5.13.6",
"5.13.5",
"5.13.1",
"5.13.0",
"5.12.6",
"5.12.5",
"5.12.0",
"5.11.5",
"5.11.0",
"5.10.5",
"5.10.0",
"5.9.5",
"5.9.0",
"5.8.5",
"5.8.0",
"5.7.5",
"5.7.0",
"5.6.5",
"5.6.1",
"5.6.0",
"5.5.0",
"5.4.6",
"5.4.5",
"5.4.0",
"5.3.5",
"5.3.0",
"5.2.7",
"5.2.6",
"5.2.5",
"5.2.3",
"5.2.2",
"5.2.1",
"5.2.0",
"5.1.8",
"5.1.7",
"5.1.6",
"5.1.5",
"5.1.0",
"5.0.5",
"5.0.2",
"5.0.1",
"5.0.0",
"v4.9.5",
"v4.9.0",
"4.8.5",
"4.8.3",
"4.8.2",
"4.8.1",
"4.7.7",
"v4.7.6"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-24145.json"
}
}
],
"modified": "2026-10-24T10:31:00.779380500Z",
"provider": "osv",
"references": [
"https://wpscan.com/vulnerability/f42cc26b-9aab-4824-8168-b5b8571d1610"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2021-24145",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 439621,
"published_at": "2021-03-18T15:15:15.4+00:00"
}