Medium
WordPress Auto Amazon Links Plugin <= 5.1.1 is vulnerable to Cross Site Scripting (XSS)
Type: advisorySources: OSV
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Michael Uno (miunosoft) Auto Amazon Links – Amazon Associates Affiliate Plugin allows Stored XSS.This issue affects Auto Amazon Links – Amazon Associates Affiliate Plugin: from n/a through 5.1.1.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2023-52175
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 18:13 UTC · Revision 1
Source evidence
WordPress Auto Amazon Links Plugin <= 5.1.1 is vulnerable to Cross Site Scripting (XSS)
core-osv · Original sourcePublished 1 Feb 2024, 10:05 UTC
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Michael Uno (miunosoft) Auto Amazon Links – Amazon Associates Affiliate Plugin allows Stored XSS.This issue affects Auto Amazon Links – Amazon Associates Affiliate Plugin: from n/a through 5.1.1.
osv:CVE-2023-52175
Complete source record
{
"id": "6e73bef57272385cf8b71491d5456eac35df88cfffe93b81ffa0ce0cdd21e6d5",
"url": "https://osv.dev/vulnerability/CVE-2023-52175",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "WordPress Auto Amazon Links Plugin <= 5.1.1 is vulnerable to Cross Site Scripting (XSS)",
"summary": "Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Michael Uno (miunosoft) Auto Amazon Links – Amazon Associates Affiliate Plugin allows Stored XSS.This issue affects Auto Amazon Links – Amazon Associates Affiliate Plugin: from n/a through 5.1.1.",
"evidence": "osv:CVE-2023-52175",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2023-52175",
"aliases": [
"CVE-2023-52175"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/michaeluno/amazon-auto-links",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "828f755aa3a8f66f41ac9ca28a0f6dcd8a6ed797"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:michaeluno:auto_amazon_links:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "5.1.2"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"5.1.1",
"5.1.0",
"5.0.7",
"5.0.6",
"5.0.5",
"5.0.4",
"5.0.3",
"5.0.2",
"5.0.1",
"5.0.0",
"4.7.9",
"4.7.8",
"4.7.7",
"4.7.6",
"4.7.5",
"4.7.4",
"4.7.3",
"4.7.2",
"4.7.1",
"4.7.0",
"4.7.0b03",
"4.6.3",
"4.6.2",
"4.6.1",
"4.6.0",
"4.5.9",
"4.5.8",
"4.5.7",
"4.5.6",
"4.5.5",
"4.5.4",
"4.5.3",
"4.5.2",
"4.5.1",
"4.5.0",
"4.4.4",
"4.4.3",
"4.4.2",
"4.4.1",
"4.4.0",
"4.3.5",
"4.3.4",
"4.3.1",
"4.3.0",
"4.2.3",
"4.2.2",
"4.2.1",
"4.2.0",
"4.1.0",
"4.0.4",
"4.0.3",
"4.0.2",
"4.0.1",
"4.0.0",
"3.11.1",
"3.11.0",
"3.10.1",
"3.10.0",
"3.9.5",
"3.9.4",
"3.9.3",
"3.9.2",
"3.9.1",
"3.9.0",
"3.8.12",
"3.8.11",
"3.8.10",
"3.8.19",
"3.8.8",
"3.8.7",
"3.8.6",
"3.8.5",
"3.8.4",
"3.8.3",
"3.8.2",
"3.8.1",
"3.8.0",
"3.7.10",
"3.7.9",
"3.7.8",
"3.7.7",
"3.7.6",
"3.7.5",
"3.7.4",
"3.7.3",
"3.7.2",
"3.7.1",
"3.7.0",
"3.6.7",
"3.6.6",
"3.6.5",
"3.6.4",
"3.6.3",
"3.6.2",
"3.6.1",
"3.6.0",
"3.5.7.1",
"3.5.7",
"3.5.6",
"3.5.5",
"3.5.4",
"3.5.3",
"3.5.2",
"3.5.1",
"3.5.0",
"3.4.13",
"3.4.12",
"3.4.11",
"3.4.10",
"3.4.9",
"3.4.8",
"3.4.7",
"3.4.6",
"3.4.5",
"3.4.4",
"3.4.3",
"3.4.2",
"3.4.1",
"3.4.0",
"3.3.6",
"3.3.5",
"3.3.4",
"3.3.1",
"3.3.0",
"3.2.4",
"3.2.3",
"3.2.2",
"3.2.1",
"3.2.0",
"3.1.4",
"3.1.3",
"3.1.2",
"3.1.1",
"3.1.0",
"3.0.5",
"3.0.4",
"3.0.3",
"3.0.2",
"3.0.1",
"3",
"2.2.1",
"2.2.0",
"2.1.2",
"2.1.1",
"2.1.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-52175.json"
}
}
],
"modified": "2026-10-28T02:30:31.293383927Z",
"provider": "osv",
"references": [
"https://wordpress.org/plugins",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/52xxx/CVE-2023-52175.json",
"https://nvd.nist.gov/vuln/detail/CVE-2023-52175",
"https://patchstack.com/database/vulnerability/amazon-auto-links/wordpress-auto-amazon-links-amazon-associates-affiliate-plugin-5-0-5-auth-stored-cross-site-scripting-xss-vulnerability?_s_id=cve"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "Patchstack",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"fixed": "5.1.2"
}
],
"source": "AFFECTED_FIELD",
"strategy": "ChangesAt"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/52xxx/CVE-2023-52175.json"
}
},
"related_cves": [
{
"value": "CVE-2023-52175",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 498322,
"published_at": "2024-02-01T10:05:06.672+00:00"
}