Skip to content
Heist/ feed
Back to feed
UnratedFix available

Drupal core - Moderately critical - Denial of Service - SA-CORE-2024-001

Type: patchSources: Drupal security

A denial-of-service vulnerability in Drupal core’s Comment module can be triggered by comment reply requests in certain cases. Sites not using the Comment module are not affected.

Products
Drupal core
Affected versions
>=8.0 <10.1.8 || >=10.2 <10.2.2
Fixed versions
Drupal 10.1.8, Drupal 10.2.2
CVEs
CVE-2024-11941
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 14:24 UTC · Revision 1

Source evidence

Drupal core - Moderately critical - Denial of Service - SA-CORE-2024-001

official-drupal-security · Original source

Published 17 Jan 2024, 17:04 UTC

A denial-of-service vulnerability in Drupal core’s Comment module can be triggered by comment reply requests in certain cases. Sites not using the Comment module are not affected.

The Comment module allows users to reply to comments. In certain cases, an attacker could make comment reply requests that would trigger a denial of service (DOS).

Drupal core

Fixed versions: Drupal 10.2.2, Drupal 10.1.8

Prerequisites: Sites that do not use the Comment module are not affected.

Complete source record
{
  "id": "2ab00be991861921addf8d67fa630cc1a6296a895e896470f84b046da0bdcf78",
  "url": "https://www.drupal.org/sa-core-2024-001",
  "method": "llm",
  "payload": {
    "kind": "patch",
    "title": "Drupal core - Moderately critical - Denial of Service - SA-CORE-2024-001",
    "summary": "A denial-of-service vulnerability in Drupal core’s Comment module can be triggered by comment reply requests in certain cases. Sites not using the Comment module are not affected.",
    "evidence": "The Comment module allows users to reply to comments. In certain cases, an attacker could make comment reply requests that would trigger a denial of service (DOS).",
    "products": [
      {
        "name": {
          "value": "Drupal core",
          "evidence": "Project: Drupal core"
        },
        "prerequisites": [
          {
            "value": "Sites that do not use the Comment module are not affected.",
            "evidence": "Sites that do not use the Comment module are not affected."
          }
        ],
        "fixed_versions": [
          {
            "value": "Drupal 10.2.2",
            "evidence": "If you are using Drupal 10.2, update to Drupal 10.2.2."
          },
          {
            "value": "Drupal 10.1.8",
            "evidence": "If you are using Drupal 10.1, update to Drupal 10.1.8."
          }
        ],
        "affected_versions": [
          {
            "value": ">=8.0 <10.1.8 || >=10.2 <10.2.2",
            "evidence": "Affected versions: >=8.0 <10.1.8 || >=10.2 <10.2.2"
          }
        ]
      }
    ],
    "severity": "unknown",
    "fixed_cves": [],
    "related_cves": [
      {
        "value": "CVE-2024-11941",
        "evidence": "CVE IDs: CVE-2024-11941"
      }
    ],
    "security_relevant": true,
    "severity_evidence": null
  },
  "source_id": "official-drupal-security",
  "document_id": 23485,
  "published_at": "2024-01-17T17:04:39+00:00"
}