Medium
Security advisory
In CLA-Assistant, versions before 2.8.5, due to improper access control an authenticated user could access API endpoints which are not intended to be used by the user. This could impact the integrity of the application.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2021-21471
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 11:32 UTC · Revision 1
Source evidence
In CLA-Assistant, versions before 2.8.5, due to improper access control an authenticated user could access API endpoints which are not intended to be used by the user. This could impact the integrity of the application.
osv:CVE-2021-21471
Complete source record
{
"id": "680bb8a4f1ef36dae246add6a8962431046b7c84118904b1fc5740a1906fb56f",
"url": "https://osv.dev/vulnerability/CVE-2021-21471",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2021-21471",
"summary": "In CLA-Assistant, versions before 2.8.5, due to improper access control an authenticated user could access API endpoints which are not intended to be used by the user. This could impact the integrity of the application.",
"evidence": "osv:CVE-2021-21471",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2021-21471",
"aliases": [
"CVE-2021-21471",
"GHSA-4h6f-c68c-pxhr"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/cla-assistant/cla-assistant",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "1256eae99184e9b6774c9f6fc51914641375cd1d"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:sap:cla-assistant:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.8.5"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v2.8.4",
"v2.8.3",
"v2.8.2",
"v2.8.1",
"v2.8.0",
"v2.7.0",
"v2.6.2",
"v2.6.1",
"v2.6.0",
"v2.5.2",
"v2.5.1",
"v2.5.0",
"v2.4.6",
"v2.4.5",
"v2.4.4",
"v2.4.3",
"v2.4.2",
"v1.10.0",
"v2.4.1",
"v2.4.0",
"v2.3.2",
"v2.3.1",
"v2.3.0",
"v2.2.1",
"v2.2.0",
"v2.1.1",
"v2.1.0",
"v2.0.3",
"v2.0.2",
"v2",
"v2.0.1",
"v2.0.0",
"v1.10.1",
"v1.9.2",
"v1.9.1",
"v1.9.0",
"v1.8.4",
"v1.8.3",
"v1.8.2",
"v1.8.1",
"v1.8.0",
"v1.7.1",
"v1.7.0",
"v1.6.0",
"v1.5.0",
"v1.4.1",
"v1.4.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-21471.json"
}
}
],
"modified": "2026-10-20T10:54:29.169958162Z",
"provider": "osv",
"references": [
"https://github.com/cla-assistant/cla-assistant/security/advisories/GHSA-4h6f-c68c-pxhr"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2021-21471",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 385446,
"published_at": "2021-01-12T15:15:16.343+00:00"
}