aiven-extras PostgreSQL Privilege Escalation Through Overloaded Search Path
aiven-extras is a PostgreSQL extension. Versions prior to 1.1.9 contain a privilege escalation vulnerability, allowing elevation to superuser inside PostgreSQL databases that use the aiven-extras package. The vulnerability leverages missing schema qualifiers on privileged functions called by the aiven-extras extension. A low privileged user can create objects that collide with existing function names, which will then be executed instead. Exploiting this vulnerability could allow a low privileged user to acquire `superuser` privileges, which would allow full, unrestricted access to all data and database functions. And could lead to arbitrary code execution or data access on the underlying host as the `postgres` user. The issue has been patched as of version 1.1.9.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2023-32305
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 15:32 UTC · Revision 1
Source evidence
aiven-extras PostgreSQL Privilege Escalation Through Overloaded Search Path
core-osv · Original sourcePublished 12 May 2023, 18:46 UTC
aiven-extras is a PostgreSQL extension. Versions prior to 1.1.9 contain a privilege escalation vulnerability, allowing elevation to superuser inside PostgreSQL databases that use the aiven-extras package. The vulnerability leverages missing schema qualifiers on privileged functions called by the aiven-extras extension. A low privileged user can create objects that collide with existing function names, which will then be executed instead. Exploiting this vulnerability could allow a low privileged user to acquire `superuser` privileges, which would allow full, unrestricted access to all data and database functions. And could lead to arbitrary code execution or data access on the underlying host as the `postgres` user. The issue has been patched as of version 1.1.9.
osv:CVE-2023-32305
Complete source record
{
"id": "a678532fbcae6424ed2f18c5c67167e77d0092b19591675a8579f0a7039873c1",
"url": "https://osv.dev/vulnerability/CVE-2023-32305",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "aiven-extras PostgreSQL Privilege Escalation Through Overloaded Search Path",
"summary": "aiven-extras is a PostgreSQL extension. Versions prior to 1.1.9 contain a privilege escalation vulnerability, allowing elevation to superuser inside PostgreSQL databases that use the aiven-extras package. The vulnerability leverages missing schema qualifiers on privileged functions called by the aiven-extras extension. A low privileged user can create objects that collide with existing function names, which will then be executed instead. Exploiting this vulnerability could allow a low privileged user to acquire `superuser` privileges, which would allow full, unrestricted access to all data and database functions. And could lead to arbitrary code execution or data access on the underlying host as the `postgres` user. The issue has been patched as of version 1.1.9.",
"evidence": "osv:CVE-2023-32305",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2023-32305",
"aliases": [
"CVE-2023-32305",
"GHSA-7r4w-fw4h-67gp"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/aiven/aiven-extras",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "36598ab226a258c8065a0aed44054089e6111241"
},
{
"fixed": "8682ae01bec0791708bf25791786d776e2fb0250"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:aiven:aiven:*:*:*:*:*:postgresql:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "1.1.9"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "8682ae01bec0791708bf25791786d776e2fb0250"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"1.1.8",
"1.1.7",
"1.1.6",
"1.1.5",
"1.1.4",
"1.1.3",
"1.1.1",
"1.0.4",
"1.0.3",
"1.0.2",
"1.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-32305.json"
}
}
],
"modified": "2026-10-28T02:30:37.002254781Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/32xxx/CVE-2023-32305.json",
"https://github.com/aiven/aiven-extras/security/advisories/GHSA-7r4w-fw4h-67gp",
"https://nvd.nist.gov/vuln/detail/CVE-2023-32305",
"https://security.netapp.com/advisory/ntap-20230616-0006/",
"https://github.com/aiven/aiven-extras/commit/8682ae01bec0791708bf25791786d776e2fb0250"
],
"provider_metadata": {
"cwe_ids": [
"CWE-1321",
"CWE-20"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/32xxx/CVE-2023-32305.json"
}
},
"related_cves": [
{
"value": "CVE-2023-32305",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 504166,
"published_at": "2023-05-12T18:46:55.995+00:00"
}