Kirby CMS vulnerable to user enumeration in the brute force protection
Kirby is a Content Management System. Prior to versions 3.5.8.2, 3.6.6.2, 3.7.5.1, and 3.8.1, a user enumeration vulnerability affects all Kirby sites with user accounts unless Kirby's API and Panel are disabled in the config. It can only be exploited for targeted attacks because the attack does not scale to brute force. The problem has been patched in Kirby 3.5.8.2, Kirby 3.6.6.2, Kirby 3.7.5.1, and Kirby 3.8.1. In all of the mentioned releases, the maintainers have rewritten the affected code so that the delay is also inserted after the brute force limit is reached.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-39315
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 14:10 UTC · Revision 1
Source evidence
Kirby CMS vulnerable to user enumeration in the brute force protection
core-osv · Original sourcePublished 25 Oct 2022, 00:00 UTC
Kirby is a Content Management System. Prior to versions 3.5.8.2, 3.6.6.2, 3.7.5.1, and 3.8.1, a user enumeration vulnerability affects all Kirby sites with user accounts unless Kirby's API and Panel are disabled in the config. It can only be exploited for targeted attacks because the attack does not scale to brute force. The problem has been patched in Kirby 3.5.8.2, Kirby 3.6.6.2, Kirby 3.7.5.1, and Kirby 3.8.1. In all of the mentioned releases, the maintainers have rewritten the affected code so that the delay is also inserted after the brute force limit is reached.
osv:CVE-2022-39315
Complete source record
{
"id": "cb83a56388a6c4f121ad31e3ae053af62743dd54e629ab4fdd218320309e577f",
"url": "https://osv.dev/vulnerability/CVE-2022-39315",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Kirby CMS vulnerable to user enumeration in the brute force protection",
"summary": "Kirby is a Content Management System. Prior to versions 3.5.8.2, 3.6.6.2, 3.7.5.1, and 3.8.1, a user enumeration vulnerability affects all Kirby sites with user accounts unless Kirby's API and Panel are disabled in the config. It can only be exploited for targeted attacks because the attack does not scale to brute force. The problem has been patched in Kirby 3.5.8.2, Kirby 3.6.6.2, Kirby 3.7.5.1, and Kirby 3.8.1. In all of the mentioned releases, the maintainers have rewritten the affected code so that the delay is also inserted after the brute force limit is reached.",
"evidence": "osv:CVE-2022-39315",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2022-39315",
"aliases": [
"CVE-2022-39315",
"GHSA-c27j-76xg-6x4f"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/getkirby/kirby",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "94a9abdfc20f1e98adb9e8696910fcd1f1d6dd99"
},
{
"introduced": "9ea05e38dbeb471657e3066651568fc29763ef06"
},
{
"fixed": "c0a92657515c90ca549fe14894cbe65a1ac99cc0"
},
{
"introduced": "d210f26602cf72c926d8ccf8befd61d7831888da"
},
{
"fixed": "9a3ecf893488df745f5516d5e490a655a4e85c21"
},
{
"introduced": "3e5899b628a2b59c1833a8d79eda292a7fe06843"
},
{
"fixed": "021ad65cc249f77415443bd357a2234494ed0dfe"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:getkirby:kirby:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "3.5.8.2"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:getkirby:kirby:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "3.6.0"
},
{
"fixed": "3.6.6.2"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:getkirby:kirby:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "3.7.0"
},
{
"fixed": "3.7.5.1"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:getkirby:kirby:3.8.0:-:*:*:*:*:*:*",
"range": [
{
"introduced": "3.8.0-NA"
},
{
"last_affected": "3.8.0-NA"
}
],
"source": "CPE_STRING"
},
{
"range": [
{
"fixed": "94a9abdfc20f1e98adb9e8696910fcd1f1d6dd99"
}
],
"source": "REFERENCES_TAG",
"original_tag": "3.5.8.2"
},
{
"range": [
{
"fixed": "c0a92657515c90ca549fe14894cbe65a1ac99cc0"
}
],
"source": "REFERENCES_TAG",
"original_tag": "3.6.6.2"
},
{
"range": [
{
"fixed": "9a3ecf893488df745f5516d5e490a655a4e85c21"
}
],
"source": "REFERENCES_TAG",
"original_tag": "3.7.5.1"
},
{
"range": [
{
"fixed": "021ad65cc249f77415443bd357a2234494ed0dfe"
}
],
"source": "REFERENCES_TAG",
"original_tag": "3.8.1"
}
]
}
}
],
"versions": [
"3.8.0-NA",
"= 3.8.0",
"3.8.0",
"3.5.8.1",
"3.6.6.1",
"3.7.5",
"3.7.4",
"3.7.3",
"3.5.8",
"3.6.6",
"3.7.4-rc.1",
"3.5.7.1",
"3.7.2.1",
"3.7.2",
"3.7.1",
"3.7.0.2",
"3.7.0.1",
"3.7.0",
"3.6.5",
"3.6.4",
"3.6.3.1",
"3.6.3",
"3.6.2",
"3.6.2-rc.3",
"3.6.2-rc.2",
"3.6.2-rc.1",
"3.6.1.1",
"3.6.0",
"3.5.7",
"3.5.6",
"3.5.5",
"3.5.4",
"3.5.3.1",
"3.5.3",
"3.5.2",
"3.5.1",
"3.5.1-rc.1",
"3.5.0",
"3.5.0-rc.7",
"3.5.0-rc.6",
"3.5.0-rc.5",
"3.5.0-rc.4",
"3.5.0-rc.3",
"3.5.0-rc.2",
"3.5.0-rc.1",
"3.4.2",
"3.4.1",
"3.4.0",
"3.3.6",
"3.3.5",
"3.3.4",
"3.3.3",
"3.3.2",
"3.3.1",
"3.3.0",
"3.2.5",
"3.2.5-rc.2",
"3.2.5-rc.1",
"3.2.3-rc.1",
"3.2.2",
"3.2.1",
"3.2.1-rc.1",
"3.2.0",
"3.2.0-rc.4",
"3.2.0-rc.3",
"3.2.0-rc.2",
"3.2.0-rc.1",
"3.1.4",
"3.1.4-rc.1",
"3.1.3",
"3.1.3-rc.1",
"3.1.2",
"3.1.2-rc.1",
"3.1.1",
"3.1.0",
"3.1.0-rc.1",
"3.0.3",
"3.0.3-rc.3",
"3.0.3-rc.2",
"3.0.3-rc.1",
"3.0.2",
"3.0.2-rc.1",
"3.0.1",
"3.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-39315.json"
}
}
],
"modified": "2026-10-28T02:30:36.089016336Z",
"provider": "osv",
"references": [
"https://github.com/getkirby/kirby/releases/tag/3.5.8.2",
"https://github.com/getkirby/kirby/releases/tag/3.6.6.2",
"https://github.com/getkirby/kirby/releases/tag/3.7.5.1",
"https://github.com/getkirby/kirby/releases/tag/3.8.1",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/39xxx/CVE-2022-39315.json",
"https://github.com/getkirby/kirby/security/advisories/GHSA-c27j-76xg-6x4f",
"https://nvd.nist.gov/vuln/detail/CVE-2022-39315"
],
"provider_metadata": {
"cwe_ids": [
"CWE-204"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/39xxx/CVE-2022-39315.json"
}
},
"related_cves": [
{
"value": "CVE-2022-39315",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 503513,
"published_at": "2022-10-25T00:00:00+00:00"
}