trafficserver security update
Apache Traffic Server is an OpenSource HTTP / HTTPS / HTTP/2 / QUIC reverse, forward and transparent proxy and cache. Security Fix(es): Improper Access Control vulnerability in Apache Traffic Server. This issue affects Apache Traffic Server: from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3. Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fixes the issue. This CVE supersedes CVE-2026-41920, whose record listed the affected 9.x versions as 9.0.0 through 9.1.14 and the fixed version as 9.1.15. All 9.2.x releases before 9.2.15 are affected.(CVE-2026-102795)
- Products
- trafficserver
- Affected versions
- Not specified
- Fixed versions
- 9.2.15-1.oe2403sp4
- CVEs
- CVE-2026-102795
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 20:39 UTC · Revision 1
Source evidence
Apache Traffic Server is an OpenSource HTTP / HTTPS / HTTP/2 / QUIC reverse, forward and transparent proxy and cache. Security Fix(es): Improper Access Control vulnerability in Apache Traffic Server. This issue affects Apache Traffic Server: from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3. Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fixes the issue. This CVE supersedes CVE-2026-41920, whose record listed the affected 9.x versions as 9.0.0 through 9.1.14 and the fixed version as 9.1.15. All 9.2.x releases before 9.2.15 are affected.(CVE-2026-102795)
osv:OESA-2026-4232
trafficserver
Fixed versions: 9.2.15-1.oe2403sp4
Complete source record
{
"id": "59fcf8baa42d9c392b3ac77418cfa14cf506ba3476ce70a8d5b5762197061514",
"url": "https://osv.dev/vulnerability/OESA-2026-4232",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "trafficserver security update",
"summary": "Apache Traffic Server is an OpenSource HTTP / HTTPS / HTTP/2 / QUIC reverse, forward and transparent proxy and cache. Security Fix(es): Improper Access Control vulnerability in Apache Traffic Server. This issue affects Apache Traffic Server: from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3. Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fixes the issue. This CVE supersedes CVE-2026-41920, whose record listed the affected 9.x versions as 9.0.0 through 9.1.14 and the fixed version as 9.1.15. All 9.2.x releases before 9.2.15 are affected.(CVE-2026-102795)",
"evidence": "osv:OESA-2026-4232",
"products": [
{
"name": {
"value": "trafficserver",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "9.2.15-1.oe2403sp4",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
}
],
"severity": "critical",
"structured": {
"id": "OESA-2026-4232",
"aliases": [
"OESA-2026-4232"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "9.2.15-1.oe2403sp4"
}
]
}
],
"package": {
"name": "trafficserver",
"purl": "pkg:rpm/openEuler/trafficserver&distro=openEuler-24.03-LTS-SP4",
"ecosystem": "openEuler:24.03-LTS-SP4"
},
"database_specific": {
"source": "https://repo.openeuler.org/security/data/osv/OESA-2026-4232.json"
},
"ecosystem_specific": {
"src": [
"trafficserver-9.2.15-1.oe2403sp4.src.rpm"
],
"x86_64": [
"trafficserver-9.2.15-1.oe2403sp4.x86_64.rpm",
"trafficserver-debuginfo-9.2.15-1.oe2403sp4.x86_64.rpm",
"trafficserver-debugsource-9.2.15-1.oe2403sp4.x86_64.rpm",
"trafficserver-devel-9.2.15-1.oe2403sp4.x86_64.rpm",
"trafficserver-perl-9.2.15-1.oe2403sp4.x86_64.rpm"
],
"aarch64": [
"trafficserver-9.2.15-1.oe2403sp4.aarch64.rpm",
"trafficserver-debuginfo-9.2.15-1.oe2403sp4.aarch64.rpm",
"trafficserver-debugsource-9.2.15-1.oe2403sp4.aarch64.rpm",
"trafficserver-devel-9.2.15-1.oe2403sp4.aarch64.rpm",
"trafficserver-perl-9.2.15-1.oe2403sp4.aarch64.rpm"
]
}
}
],
"modified": "2026-10-16T12:15:05.094985032Z",
"provider": "osv",
"upstream": [
"CVE-2026-102795"
],
"references": [
"https://www.openeuler.org/zh/security/security-bulletins/detail/?id=openEuler-SA-2026-4232",
"https://nvd.nist.gov/vuln/detail/CVE-2026-102795"
],
"provider_metadata": {
"severity": "Critical"
}
},
"related_cves": [
{
"value": "CVE-2026-102795",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/database_specific/severity"
},
"source_id": "core-osv",
"document_id": 340751,
"published_at": "2026-10-16T11:58:25+00:00"
}