Skip to content
Heist/ feed
Back to feed
Medium

DOM-based XSS in GoCD

Type: advisorySources: OSV

GoCD is a continuous delivery server. GoCD versions 19.11.0 through 21.4.0 (inclusive) are vulnerable to a Document Object Model (DOM)-based cross-site scripting attack via a pipeline run's Stage Details > Graphs tab. It is possible for a malicious script on a attacker-hosted site to execute script that will run within the user's browser context and GoCD session via abuse of a messaging channel used for communication between with the parent page and the stage details graph's iframe. This could allow an attacker to steal a GoCD user's session cookies and/or execute malicious code in the user's context. This issue is fixed in GoCD 22.1.0. There are currently no known workarounds.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2022-29182
Confirmed fixed CVEs
Not specified
Updated in this feed
2 Nov 2026, 19:11 UTC · Revision 1

Source evidence

DOM-based XSS in GoCD

core-osv · Original source

Published 20 May 2022, 19:05 UTC

GoCD is a continuous delivery server. GoCD versions 19.11.0 through 21.4.0 (inclusive) are vulnerable to a Document Object Model (DOM)-based cross-site scripting attack via a pipeline run's Stage Details > Graphs tab. It is possible for a malicious script on a attacker-hosted site to execute script that will run within the user's browser context and GoCD session via abuse of a messaging channel used for communication between with the parent page and the stage details graph's iframe. This could allow an attacker to steal a GoCD user's session cookies and/or execute malicious code in the user's context. This issue is fixed in GoCD 22.1.0. There are currently no known workarounds.

osv:CVE-2022-29182
Complete source record
{
  "id": "1fd1d52dfa02960449151f3e081d8401d127bbe2f00f65a5e32e99c6043f6fe0",
  "url": "https://osv.dev/vulnerability/CVE-2022-29182",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DOM-based XSS in GoCD",
    "summary": "GoCD is a continuous delivery server. GoCD versions 19.11.0 through 21.4.0 (inclusive) are vulnerable to a Document Object Model (DOM)-based cross-site scripting attack via a pipeline run's Stage Details > Graphs tab. It is possible for a malicious script on a attacker-hosted site to execute script that will run within the user's browser context and GoCD session via abuse of a messaging channel used for communication between with the parent page and the stage details graph's iframe. This could allow an attacker to steal a GoCD user's session cookies and/or execute malicious code in the user's context. This issue is fixed in GoCD 22.1.0. There are currently no known workarounds.",
    "evidence": "osv:CVE-2022-29182",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2022-29182",
      "aliases": [
        "CVE-2022-29182",
        "GHSA-qcg6-4q44-3589"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/gocd/gocd",
              "type": "GIT",
              "events": [
                {
                  "introduced": "c532a61bb240ffbe59fe356445bea6433005563f"
                },
                {
                  "fixed": "f4c9c1650e2e27fe0a9962faa39536f94f57e297"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:thoughtworks:gocd:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "19.11.0"
                      },
                      {
                        "last_affected": "21.4.0"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "f4c9c1650e2e27fe0a9962faa39536f94f57e297"
                      }
                    ],
                    "source": "REFERENCES_TAG",
                    "original_tag": "22.1.0"
                  }
                ]
              }
            }
          ],
          "versions": [
            "21.4.0",
            "21.3.0",
            "21.2.0",
            "21.1.0",
            "20.10.0",
            "20.9.0",
            "20.8.0",
            "20.7.0",
            "20.6.0",
            "20.5.0",
            "20.4.0",
            "20.3.0",
            "20.2.0",
            "20.1.0",
            "19.12.0",
            "19.11.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-29182.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:22.861514906Z",
      "provider": "osv",
      "references": [
        "https://github.com/gocd/gocd/pull/10190/commits/a256d05de1445e6c77843f098581fc6a66fe4477",
        "https://github.com/gocd/gocd/releases/tag/22.1.0",
        "https://www.gocd.org/releases/#22-1-0",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/29xxx/CVE-2022-29182.json",
        "https://github.com/gocd/gocd/security/advisories/GHSA-qcg6-4q44-3589",
        "https://nvd.nist.gov/vuln/detail/CVE-2022-29182"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-79"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/29xxx/CVE-2022-29182.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2022-29182",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 489010,
  "published_at": "2022-05-20T19:05:12+00:00"
}