Security advisory
pam-krb5 before 4.9 has a buffer overflow that might cause remote code execution in situations involving supplemental prompting by a Kerberos library. It may overflow a buffer provided by the underlying Kerberos library by a single '\0' byte if an attacker responds to a prompt with an answer of a carefully chosen length. The effect may range from heap corruption to stack corruption depending on the structure of the underlying Kerberos library, with unknown effects but possibly including code execution. This code path is not used for normal authentication, but only when the Kerberos library does supplemental prompting, such as with PKINIT or when using the non-standard no_prompt PAM configuration option.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2020-10595
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 10:48 UTC · Revision 1
Source evidence
pam-krb5 before 4.9 has a buffer overflow that might cause remote code execution in situations involving supplemental prompting by a Kerberos library. It may overflow a buffer provided by the underlying Kerberos library by a single '\0' byte if an attacker responds to a prompt with an answer of a carefully chosen length. The effect may range from heap corruption to stack corruption depending on the structure of the underlying Kerberos library, with unknown effects but possibly including code execution. This code path is not used for normal authentication, but only when the Kerberos library does supplemental prompting, such as with PKINIT or when using the non-standard no_prompt PAM configuration option.
osv:CVE-2020-10595
Complete source record
{
"id": "c18644a75399040748890e52f9bfe724961eeb0af25a3eb6975d394ea6951600",
"url": "https://osv.dev/vulnerability/CVE-2020-10595",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2020-10595",
"summary": "pam-krb5 before 4.9 has a buffer overflow that might cause remote code execution in situations involving supplemental prompting by a Kerberos library. It may overflow a buffer provided by the underlying Kerberos library by a single '\\0' byte if an attacker responds to a prompt with an answer of a carefully chosen length. The effect may range from heap corruption to stack corruption depending on the structure of the underlying Kerberos library, with unknown effects but possibly including code execution. This code path is not used for normal authentication, but only when the Kerberos library does supplemental prompting, such as with PKINIT or when using the non-standard no_prompt PAM configuration option.",
"evidence": "osv:CVE-2020-10595",
"products": [],
"severity": "critical",
"structured": {
"id": "CVE-2020-10595",
"aliases": [
"CVE-2020-10595"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/rra/pam-krb5",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "b8817fea4b8c59f8fd6ecec64ba1d1f86e00d9ba"
},
{
"fixed": "e7879e27a37119fad4faf133a9f70bdcdc75d760"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:pam-krb5_project:pam-krb5:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "4.9"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "e7879e27a37119fad4faf133a9f70bdcdc75d760"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
}
],
"versions": [
"upstream/4.8",
"upstream/4.7",
"release/4.8",
"release/4.7",
"upstream/4.6",
"release/4.6",
"upstream/4.5",
"release/4.5",
"release/4.4",
"upstream/4.4",
"upstream/4.3",
"release/4.3",
"upstream/4.2",
"release/4.2",
"upstream/4.1",
"release/4.1",
"upstream/4.0",
"release/4.0",
"upstream/3.15",
"release/3.15",
"upstream/3.14",
"release/3.14",
"upstream/3.13",
"release/3.13",
"upstream/3.12",
"release/3.12",
"upstream/3.11",
"release/3.11",
"upstream/3.10",
"release/3.10",
"upstream/3.9",
"release/3.9",
"upstream/3.8",
"release/3.8",
"upstream/3.7",
"upstream/3.6",
"release/3.7",
"release/3.6",
"upstream/3.5",
"release/3.5",
"upstream/2.6",
"release/3.4",
"release/3.3",
"release/3.2",
"release/3.1",
"release/3.0",
"release/2.6",
"upstream/2.5",
"release/2.5",
"upstream/2.4",
"release/2.4",
"upstream/2.3",
"release/2.3",
"upstream/2.2",
"release/2.2",
"upstream/2.1",
"release/2.1",
"upstream/2.0",
"release/2.0",
"upstream/1.2.0",
"release/1.2"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2020-10595.json"
}
}
],
"modified": "2026-10-20T10:51:45.107248379Z",
"provider": "osv",
"references": [
"https://usn.ubuntu.com/4314-1/",
"https://www.eyrie.org/~eagle/software/pam-krb5/security/2020-03-30.html",
"https://lists.debian.org/debian-lts-announce/2020/04/msg00000.html",
"https://www.debian.org/security/2020/dsa-4648",
"https://github.com/rra/pam-krb5/commit/e7879e27a37119fad4faf133a9f70bdcdc75d760"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*",
"cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*",
"cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*"
],
"vendor_product": "debian:debian_linux",
"extracted_events": [
{
"range": [
{
"introduced": "8.0"
},
{
"last_affected": "8.0"
},
{
"introduced": "9.0"
},
{
"last_affected": "9.0"
},
{
"introduced": "10.0"
},
{
"last_affected": "10.0"
}
],
"source": "CPE_STRING"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2020-10595",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 382862,
"published_at": "2020-03-31T13:15:13.13+00:00"
}