High
Security advisory
Roxy-WI is a Web interface for managing Haproxy, Nginx, Apache, and Keepalived servers. Versions prior to 6.3.5.0 have a directory traversal vulnerability that allows the inclusion of server-side files. This issue is fixed in version 6.3.5.0.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2023-25803
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 2 Nov 2026, 18:08 UTC · Revision 1
Source evidence
Roxy-WI is a Web interface for managing Haproxy, Nginx, Apache, and Keepalived servers. Versions prior to 6.3.5.0 have a directory traversal vulnerability that allows the inclusion of server-side files. This issue is fixed in version 6.3.5.0.
osv:CVE-2023-25803
Complete source record
{
"id": "de6189dcbdca6c17accaaf1b5f855ce42aa7ab03278ea35889684ea83dcef1cb",
"url": "https://osv.dev/vulnerability/CVE-2023-25803",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2023-25803",
"summary": "Roxy-WI is a Web interface for managing Haproxy, Nginx, Apache, and Keepalived servers. Versions prior to 6.3.5.0 have a directory traversal vulnerability that allows the inclusion of server-side files. This issue is fixed in version 6.3.5.0.",
"evidence": "osv:CVE-2023-25803",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2023-25803",
"aliases": [
"CVE-2023-25803",
"GHSA-cv9w-j9gh-5j3w"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/roxy-wi/roxy-wi",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "f9c324da13adf8b0f6e3c016cf10204e56c61803"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "6.3.5.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"cpe": "cpe:2.3:a:roxy-wi:roxy-wi:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "6.3.5.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v6.3.4.0",
"v6.3.3.0",
"v6.3.2.0",
"v6.3.1.0",
"v6.3.0.0",
"v6.2.3.0",
"v6.2.2.0",
"v6.2.1.0",
"v6.2.0.0",
"v6.1.5.0",
"v6.1.4.0",
"v6.1.3.0",
"v6.1.2.0",
"v6.1.1.0",
"v6.1.0.0",
"v6.0.3.0",
"v6.0.2.0",
"v6.0.1.0",
"v6.0.0.0",
"v5.5.1.0",
"v5.5.0.0",
"v5.4.3.0",
"v5.4.2.0",
"v5.4.1.0",
"v5.4.0.0",
"v5.3.6.0",
"v.5.3.5.0",
"v5.3.4.0",
"v5.3.3.0",
"v5.3.2.0",
"v5.3.1.0",
"v5.3.0.0",
"v5.2.6.0",
"v5.2.5.0",
"v5.2.4.0",
"v5.2.3.0",
"v5.2.2.0",
"v5.2.1",
"v5.2.0",
"v5.1.4.0",
"v5.1.1.0",
"v4.4.1.0",
"3.4.5.1",
"3.4.5",
"3.4.4.7",
"3.4.4.6",
"v3.3",
"v3.2.13",
"v2.0.2",
"v1.10.2.1",
"v1.10.2",
"v1.10.1",
"v1.10",
"v1.9.1",
"v1.6",
"v1.4.1",
"v1.4",
"v1.3",
"v1.1",
"v1.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-25803.json"
}
}
],
"modified": "2026-10-28T02:30:21.799518469Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/25xxx/CVE-2023-25803.json",
"https://github.com/hap-wi/roxy-wi/security/advisories/GHSA-cv9w-j9gh-5j3w",
"https://nvd.nist.gov/vuln/detail/CVE-2023-25803"
],
"provider_metadata": {
"cwe_ids": [
"CWE-22"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2023/25xxx/CVE-2023-25803.json"
}
},
"related_cves": [
{
"value": "CVE-2023-25803",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 488110,
"published_at": "2023-03-13T00:00:00+00:00"
}