HighFix available
wolfssl — security advisory
In wolfSSL before 5.2.0, a TLS 1.3 server cannot properly enforce a requirement for mutual authentication. A client can simply omit the certificate_verify message from the handshake, and never present a certificate.
- Products
- wolfssl
- Affected versions
- Not specified
- Fixed versions
- 5.2.0-1
- CVEs
- CVE-2022-25640
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 14:48 UTC · Revision 1
Source evidence
In wolfSSL before 5.2.0, a TLS 1.3 server cannot properly enforce a requirement for mutual authentication. A client can simply omit the certificate_verify message from the handshake, and never present a certificate.
osv:DEBIAN-CVE-2022-25640
wolfssl
Fixed versions: 5.2.0-1
wolfssl
Fixed versions: 5.2.0-1
Complete source record
{
"id": "5095ce5b415dae542646142a09465ce9d0e9763e0e2d4d163d41f0018febe3b2",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-25640",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2022-25640",
"summary": "In wolfSSL before 5.2.0, a TLS 1.3 server cannot properly enforce a requirement for mutual authentication. A client can simply omit the certificate_verify message from the handshake, and never present a certificate.",
"evidence": "osv:DEBIAN-CVE-2022-25640",
"products": [
{
"name": {
"value": "wolfssl",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "5.2.0-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "wolfssl",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "5.2.0-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2022-25640",
"aliases": [
"DEBIAN-CVE-2022-25640"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "5.2.0-1"
}
]
}
],
"package": {
"name": "wolfssl",
"purl": "pkg:deb/debian/wolfssl?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-25640.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "5.2.0-1"
}
]
}
],
"package": {
"name": "wolfssl",
"purl": "pkg:deb/debian/wolfssl?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-25640.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-15T08:02:21.324197899Z",
"provider": "osv",
"upstream": [
"CVE-2022-25640"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2022-25640"
]
},
"related_cves": [
{
"value": "CVE-2022-25640",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 323374,
"published_at": "2022-02-24T15:15:32.087+00:00"
}