Skip to content
Heist/ feed
Back to feed
HighFix available

sensible-utils — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2017-17512

sensible-browser in sensible-utils before 0.0.11 does not validate strings before launching the program specified by the BROWSER environment variable, which allows remote attackers to conduct argument-injection attacks via a crafted URL, as demonstrated by a --proxy-pac-file argument.

Products
sensible-utils
Affected versions
Not specified
Fixed versions
0.0.11
CVEs
CVE-2017-17512
Confirmed fixed CVEs
Not specified
Updated in this feed
30 Oct 2026, 14:30 UTC · Revision 1

Source evidence

DEBIAN-CVE-2017-17512

core-osv · Original source

Published 11 Dec 2017, 06:29 UTC

sensible-browser in sensible-utils before 0.0.11 does not validate strings before launching the program specified by the BROWSER environment variable, which allows remote attackers to conduct argument-injection attacks via a crafted URL, as demonstrated by a --proxy-pac-file argument.

osv:DEBIAN-CVE-2017-17512

sensible-utils

Fixed versions: 0.0.11

sensible-utils

Fixed versions: 0.0.11

sensible-utils

Fixed versions: 0.0.11

Complete source record
{
  "id": "dd2434dbe7aa62574f8476152aff9c28ed848928b557708af81d4f88d3d103ce",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2017-17512",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2017-17512",
    "summary": "sensible-browser in sensible-utils before 0.0.11 does not validate strings before launching the program specified by the BROWSER environment variable, which allows remote attackers to conduct argument-injection attacks via a crafted URL, as demonstrated by a --proxy-pac-file argument.",
    "evidence": "osv:DEBIAN-CVE-2017-17512",
    "products": [
      {
        "name": {
          "value": "sensible-utils",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "0.0.11",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "sensible-utils",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "0.0.11",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "sensible-utils",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "0.0.11",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "high",
    "structured": {
      "id": "DEBIAN-CVE-2017-17512",
      "aliases": [
        "DEBIAN-CVE-2017-17512"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "0.0.11"
                }
              ]
            }
          ],
          "package": {
            "name": "sensible-utils",
            "purl": "pkg:deb/debian/sensible-utils?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2017-17512.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "0.0.11"
                }
              ]
            }
          ],
          "package": {
            "name": "sensible-utils",
            "purl": "pkg:deb/debian/sensible-utils?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2017-17512.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "0.0.11"
                }
              ]
            }
          ],
          "package": {
            "name": "sensible-utils",
            "purl": "pkg:deb/debian/sensible-utils?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2017-17512.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-15T07:47:38.314056111Z",
      "provider": "osv",
      "upstream": [
        "CVE-2017-17512"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2017-17512"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2017-17512",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 322332,
  "published_at": "2017-12-11T06:29:00.27+00:00"
}