CKEditor4 Cross-site scripting (XSS) vulnerability caused by incorrect CDATA detection
CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A cross-site scripting vulnerability has been discovered in the core HTML parsing module in versions of CKEditor4 prior to 4.24.0-lts. It may affect all editor instances that enabled full-page editing mode or enabled CDATA elements in Advanced Content Filtering configuration (defaults to `script` and `style` elements). The vulnerability allows attackers to inject malformed HTML content bypassing Advanced Content Filtering mechanism, which could result in executing JavaScript code. An attacker could abuse faulty CDATA content detection and use it to prepare an intentional attack on the editor. A fix is available in version 4.24.0-lts.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-24815
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 5 Nov 2026, 04:08 UTC · Revision 1
Source evidence
CKEditor4 Cross-site scripting (XSS) vulnerability caused by incorrect CDATA detection
core-osv · Original sourcePublished 7 Feb 2024, 15:14 UTC
CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A cross-site scripting vulnerability has been discovered in the core HTML parsing module in versions of CKEditor4 prior to 4.24.0-lts. It may affect all editor instances that enabled full-page editing mode or enabled CDATA elements in Advanced Content Filtering configuration (defaults to `script` and `style` elements). The vulnerability allows attackers to inject malformed HTML content bypassing Advanced Content Filtering mechanism, which could result in executing JavaScript code. An attacker could abuse faulty CDATA content detection and use it to prepare an intentional attack on the editor. A fix is available in version 4.24.0-lts.
osv:CVE-2024-24815
Complete source record
{
"id": "0f0f67062bdbc64047fb2de69fc4585106952fd3938d634dbaa5faceb9cc9fba",
"url": "https://osv.dev/vulnerability/CVE-2024-24815",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CKEditor4 Cross-site scripting (XSS) vulnerability caused by incorrect CDATA detection",
"summary": "CKEditor4 is an open source what-you-see-is-what-you-get HTML editor. A cross-site scripting vulnerability has been discovered in the core HTML parsing module in versions of CKEditor4 prior to 4.24.0-lts. It may affect all editor instances that enabled full-page editing mode or enabled CDATA elements in Advanced Content Filtering configuration (defaults to `script` and `style` elements). The vulnerability allows attackers to inject malformed HTML content bypassing Advanced Content Filtering mechanism, which could result in executing JavaScript code. An attacker could abuse faulty CDATA content detection and use it to prepare an intentional attack on the editor. A fix is available in version 4.24.0-lts.",
"evidence": "osv:CVE-2024-24815",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2024-24815",
"aliases": [
"CVE-2024-24815",
"GHSA-fq6h-4g8v-qqvm"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/ckeditor/ckeditor4",
"type": "GIT",
"events": [
{
"introduced": "769d96134bcf29f5d3d870e25797ce9b9dc8289e"
},
{
"fixed": "d9ccba34d186be696f1322a0fde29660b1840279"
},
{
"fixed": "8ed1a3c93d0ae5f49f4ecff5738ab8a2972194cb"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:ckeditor:ckeditor:*:*:*:*:lts:*:*:*",
"range": [
{
"introduced": "4.0"
},
{
"fixed": "4.24.0"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "8ed1a3c93d0ae5f49f4ecff5738ab8a2972194cb"
}
],
"source": "REFERENCES_COMMIT"
}
]
}
},
{
"repo": "https://github.com/ckeditor/ckeditor4-releases",
"type": "GIT",
"events": [
{
"introduced": "870a561110a23435d78eda377400dca7f64d3bd3"
},
{
"fixed": "84dd70230eb0f2a3c479a0e63aaa5fa108b3293d"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:ckeditor:ckeditor:*:*:*:*:lts:*:*:*",
"range": [
{
"introduced": "4.0"
},
{
"fixed": "4.24.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"4.23.0-lts",
"4.22.1",
"4.22.0",
"4.21.0",
"4.20.2",
"4.20.1",
"4.20.0",
"4.19.1",
"4.19.0",
"4.18.0",
"4.17.2",
"4.17.1",
"4.17.0",
"4.16.0",
"4.15.0",
"4.14.0",
"4.13.0",
"4.12.0",
"4.10.0",
"4.8.0",
"4.7.0",
"4.6.0",
"4.5.0",
"4.5.0-beta",
"4.4.1",
"4.4.0",
"4.2.3",
"4.2.2",
"4.2.1",
"4.2.0",
"4.2",
"4.1.0",
"4.1",
"4.1rc",
"4.0.1",
"4.0.0",
"4.0",
"standard/4.23.0-lts",
"standard/4.22.1",
"standard/4.22.0",
"standard/4.21.0",
"standard/4.20.2",
"standard/4.20.1",
"standard/4.20.0",
"standard/4.19.1",
"standard/4.19.0",
"standard/4.18.0",
"standard/4.17.2",
"standard/4.17.1",
"standard/4.17.0",
"standard/4.16.2",
"standard/4.16.1",
"standard/4.16.0",
"standard/4.15.1",
"standard/4.15.0",
"standard/4.14.1",
"standard/4.14.0",
"standard/4.13.1",
"standard/4.13.0",
"standard/4.12.1",
"standard/4.12.0",
"standard/4.11.4",
"standard/4.11.3",
"standard/4.11.2",
"standard/4.11.1",
"standard/4.11.0",
"standard/4.10.1",
"standard/4.10.0",
"standard/4.9.2",
"standard/4.9.1",
"standard/4.9.0",
"standard/4.8.0",
"standard/4.7.3",
"standard/4.7.2",
"standard/4.7.1",
"standard/4.7.0",
"standard/4.6.2",
"standard/4.6.1",
"standard/4.6.0",
"standard/4.5.11",
"standard/4.5.10",
"standard/4.5.9",
"standard/4.5.8",
"standard/4.5.7",
"standard/4.5.6",
"standard/4.5.5",
"standard/4.5.4",
"standard/4.5.3",
"standard/4.5.2",
"standard/4.5.1",
"standard/4.5.0",
"standard/4.4.8",
"standard/4.4.7",
"standard/4.4.6",
"standard/4.4.5",
"standard/4.4.4",
"standard/4.4.3",
"standard/4.4.2",
"standard/4.4.1",
"standard/4.4.0",
"standard/4.3.5",
"standard/4.3.4",
"standard/4.3.3",
"4.3.2/standard",
"4.3.1/standard",
"4.3.0/standard",
"4.2.3/standard",
"4.2.2/standard",
"4.2.1/standard",
"4.2/standard",
"4.1.3/standard",
"4.1.2/standard",
"4.1.1/standard",
"4.1/standard",
"4.1rc/standard",
"4.0.1/standard",
"4.0/standard"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-24815.json"
}
}
],
"modified": "2026-10-28T02:30:42.322658822Z",
"provider": "osv",
"references": [
"https://ckeditor.com/docs/ckeditor4/latest/api/CKEDITOR_dtd.html#property-S-cdata",
"https://ckeditor.com/docs/ckeditor4/latest/features/fullpage.html",
"https://ckeditor.com/docs/ckeditor4/latest/guide/dev_advanced_content_filter.html",
"https://www.drupal.org/sa-contrib-2024-009",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/24xxx/CVE-2024-24815.json",
"https://github.com/ckeditor/ckeditor4/security/advisories/GHSA-fq6h-4g8v-qqvm",
"https://nvd.nist.gov/vuln/detail/CVE-2024-24815",
"https://github.com/ckeditor/ckeditor4/commit/8ed1a3c93d0ae5f49f4ecff5738ab8a2972194cb"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/24xxx/CVE-2024-24815.json"
}
},
"related_cves": [
{
"value": "CVE-2024-24815",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 510144,
"published_at": "2024-02-07T15:14:32.361+00:00"
}