High
Apache Commons Compress: Denial of service caused by an infinite loop for a corrupted DUMP file
Type: advisorySources: OSV
Loop with Unreachable Exit Condition ('Infinite Loop') vulnerability in Apache Commons Compress.This issue affects Apache Commons Compress: from 1.3 through 1.25.0. Users are recommended to upgrade to version 1.26.0 which fixes the issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-25710
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 2 Nov 2026, 19:45 UTC · Revision 1
Source evidence
Apache Commons Compress: Denial of service caused by an infinite loop for a corrupted DUMP file
core-osv · Original sourcePublished 19 Feb 2024, 08:33 UTC
Loop with Unreachable Exit Condition ('Infinite Loop') vulnerability in Apache Commons Compress.This issue affects Apache Commons Compress: from 1.3 through 1.25.0. Users are recommended to upgrade to version 1.26.0 which fixes the issue.
osv:CVE-2024-25710
Complete source record
{
"id": "4a40aeb56ee58ea8f363787ce3fd3a5010fba6c087eeae851178b120034f18b1",
"url": "https://osv.dev/vulnerability/CVE-2024-25710",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache Commons Compress: Denial of service caused by an infinite loop for a corrupted DUMP file",
"summary": "Loop with Unreachable Exit Condition ('Infinite Loop') vulnerability in Apache Commons Compress.This issue affects Apache Commons Compress: from 1.3 through 1.25.0. Users are recommended to upgrade to version 1.26.0 which fixes the issue.",
"evidence": "osv:CVE-2024-25710",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2024-25710",
"aliases": [
"CVE-2024-25710",
"GHSA-4g9r-vxhx-9pgx"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/commons-compress",
"type": "GIT",
"events": [
{
"introduced": "0874320927ef9427cf5da5973935a1d17201cdf7"
},
{
"fixed": "acaf5642b1e16d872870a4dc4618e46ccd349493"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:commons_compress:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "1.3"
},
{
"fixed": "1.26.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-25710.json"
}
}
],
"modified": "2026-10-28T02:30:22.919145165Z",
"provider": "osv",
"references": [
"https://repo.maven.apache.org/maven2/",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/25xxx/CVE-2024-25710.json",
"https://lists.apache.org/thread/cz8qkcwphy4cx8gltn932ln51cbtq6kf",
"https://nvd.nist.gov/vuln/detail/CVE-2024-25710",
"https://security.netapp.com/advisory/ntap-20240307-0010/"
],
"provider_metadata": {
"cwe_ids": [
"CWE-835"
],
"cna_assigner": "apache",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "1.3"
},
{
"last_affected": "1.25.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/25xxx/CVE-2024-25710.json"
}
},
"related_cves": [
{
"value": "CVE-2024-25710",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 489313,
"published_at": "2024-02-19T08:33:40.627+00:00"
}