node-markdown-it — security advisory
A vulnerability was found in markdown-it up to 2.x. It has been classified as problematic. Affected is an unknown function of the file lib/common/html_re.js. The manipulation leads to inefficient regular expression complexity. Upgrading to version 3.0.0 is able to address this issue. The name of the patch is 89c8620157d6e38f9872811620d25138fc9d1b0d. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-216852.
- Products
- node-markdown-it
- Affected versions
- 10.0.0+dfsg-2, 10.0.0+dfsg-3, 10.0.0+dfsg-3.1, 10.0.0+dfsg-4, 10.0.0+dfsg-5, 10.0.0+dfsg-6, 22.2.3+dfsg+~12.2.3-2, 22.2.3+dfsg+~12.2.3-4, 22.2.3+dfsg+~12.2.3-5
- Fixed versions
- Not specified
- CVEs
- CVE-2015-10005
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 00:21 UTC · Revision 1
Source evidence
A vulnerability was found in markdown-it up to 2.x. It has been classified as problematic. Affected is an unknown function of the file lib/common/html_re.js. The manipulation leads to inefficient regular expression complexity. Upgrading to version 3.0.0 is able to address this issue. The name of the patch is 89c8620157d6e38f9872811620d25138fc9d1b0d. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-216852.
osv:UBUNTU-CVE-2015-10005
node-markdown-it
Fixed versions: Not specified
node-markdown-it
Fixed versions: Not specified
node-markdown-it
Fixed versions: Not specified
node-markdown-it
Fixed versions: Not specified
node-markdown-it
Fixed versions: Not specified
Complete source record
{
"id": "829ae0df8ee259338660c24faff0a482bcc5454cc76dedb640f4be2e68ac437d",
"url": "https://osv.dev/vulnerability/UBUNTU-CVE-2015-10005",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "UBUNTU-CVE-2015-10005",
"summary": "A vulnerability was found in markdown-it up to 2.x. It has been classified as problematic. Affected is an unknown function of the file lib/common/html_re.js. The manipulation leads to inefficient regular expression complexity. Upgrading to version 3.0.0 is able to address this issue. The name of the patch is 89c8620157d6e38f9872811620d25138fc9d1b0d. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-216852.",
"evidence": "osv:UBUNTU-CVE-2015-10005",
"products": [
{
"name": {
"value": "node-markdown-it",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "10.0.0+dfsg-2",
"evidence": "/affected/0/versions"
},
{
"value": "10.0.0+dfsg-3",
"evidence": "/affected/0/versions"
},
{
"value": "10.0.0+dfsg-3.1",
"evidence": "/affected/0/versions"
},
{
"value": "10.0.0+dfsg-4",
"evidence": "/affected/0/versions"
},
{
"value": "10.0.0+dfsg-5",
"evidence": "/affected/0/versions"
},
{
"value": "10.0.0+dfsg-6",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "node-markdown-it",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "22.2.3+dfsg+~12.2.3-2",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "node-markdown-it",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "22.2.3+dfsg+~12.2.3-2",
"evidence": "/affected/2/versions"
}
]
},
{
"name": {
"value": "node-markdown-it",
"evidence": "/affected/3/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "22.2.3+dfsg+~12.2.3-4",
"evidence": "/affected/3/versions"
},
{
"value": "22.2.3+dfsg+~12.2.3-5",
"evidence": "/affected/3/versions"
}
]
},
{
"name": {
"value": "node-markdown-it",
"evidence": "/affected/4/package/name"
},
"prerequisites": [],
"fixed_versions": [],
"affected_versions": [
{
"value": "22.2.3+dfsg+~12.2.3-2",
"evidence": "/affected/4/versions"
},
{
"value": "22.2.3+dfsg+~12.2.3-4",
"evidence": "/affected/4/versions"
}
]
}
],
"severity": "high",
"structured": {
"id": "UBUNTU-CVE-2015-10005",
"aliases": [
"UBUNTU-CVE-2015-10005"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L"
},
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
},
{
"type": "Ubuntu",
"score": "medium"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "node-markdown-it",
"purl": "pkg:deb/ubuntu/node-markdown-it?arch=source&distro=jammy",
"ecosystem": "Ubuntu:22.04:LTS"
},
"versions": [
"10.0.0+dfsg-2",
"10.0.0+dfsg-3",
"10.0.0+dfsg-3.1",
"10.0.0+dfsg-4",
"10.0.0+dfsg-5",
"10.0.0+dfsg-6"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2015/UBUNTU-CVE-2015-10005.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "node-markdown-it",
"binary_version": "10.0.0+dfsg-6"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "node-markdown-it",
"purl": "pkg:deb/ubuntu/node-markdown-it?arch=source&distro=noble",
"ecosystem": "Ubuntu:24.04:LTS"
},
"versions": [
"22.2.3+dfsg+~12.2.3-2"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2015/UBUNTU-CVE-2015-10005.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "node-markdown-it",
"binary_version": "22.2.3+dfsg+~12.2.3-2"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "node-markdown-it",
"purl": "pkg:deb/ubuntu/node-markdown-it?arch=source&distro=questing",
"ecosystem": "Ubuntu:25.10"
},
"versions": [
"22.2.3+dfsg+~12.2.3-2"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2015/UBUNTU-CVE-2015-10005.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "node-markdown-it",
"binary_version": "22.2.3+dfsg+~12.2.3-2"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "node-markdown-it",
"purl": "pkg:deb/ubuntu/node-markdown-it?arch=source&distro=stonking",
"ecosystem": "Ubuntu:26.10"
},
"versions": [
"22.2.3+dfsg+~12.2.3-4",
"22.2.3+dfsg+~12.2.3-5"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2015/UBUNTU-CVE-2015-10005.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "node-markdown-it",
"binary_version": "22.2.3+dfsg+~12.2.3-5"
}
]
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
}
]
}
],
"package": {
"name": "node-markdown-it",
"purl": "pkg:deb/ubuntu/node-markdown-it?arch=source&distro=resolute",
"ecosystem": "Ubuntu:26.04:LTS"
},
"versions": [
"22.2.3+dfsg+~12.2.3-2",
"22.2.3+dfsg+~12.2.3-4"
],
"database_specific": {
"source": "https://github.com/canonical/ubuntu-security-notices/blob/main/osv/cve/2015/UBUNTU-CVE-2015-10005.json"
},
"ecosystem_specific": {
"binaries": [
{
"binary_name": "node-markdown-it",
"binary_version": "22.2.3+dfsg+~12.2.3-4"
}
]
}
}
],
"modified": "2026-10-17T12:52:52.101853148Z",
"provider": "osv",
"upstream": [
"CVE-2015-10005"
],
"references": [
"https://ubuntu.com/security/CVE-2015-10005",
"https://github.com/markdown-it/markdown-it/releases/tag/3.0.0",
"https://www.cve.org/CVERecord?id=CVE-2015-10005"
]
},
"related_cves": [
{
"value": "CVE-2015-10005",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/1/score"
},
"source_id": "core-osv",
"document_id": 353331,
"published_at": "2022-12-27T09:15:00+00:00"
}