Medium
Apache Traffic Server: ACL is not fully compatible with older versions
Type: advisorySources: OSV
Improper Access Control vulnerability in Apache Traffic Server. This issue affects Apache Traffic Server: from 10.0.0 through 10.0.3. Users are recommended to upgrade to version 10.0.4, which fixes the issue.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-56196
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 01:23 UTC · Revision 1
Source evidence
Apache Traffic Server: ACL is not fully compatible with older versions
core-osv · Original sourcePublished 6 Mar 2025, 11:21 UTC
Improper Access Control vulnerability in Apache Traffic Server. This issue affects Apache Traffic Server: from 10.0.0 through 10.0.3. Users are recommended to upgrade to version 10.0.4, which fixes the issue.
osv:CVE-2024-56196
Complete source record
{
"id": "b611b3f0f06dd39411931e7d9c17a6423ec7e454527525920e24ba1f8b656b46",
"url": "https://osv.dev/vulnerability/CVE-2024-56196",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Apache Traffic Server: ACL is not fully compatible with older versions",
"summary": "Improper Access Control vulnerability in Apache Traffic Server. This issue affects Apache Traffic Server: from 10.0.0 through 10.0.3. Users are recommended to upgrade to version 10.0.4, which fixes the issue.",
"evidence": "osv:CVE-2024-56196",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2024-56196",
"aliases": [
"CVE-2024-56196"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/apache/trafficserver",
"type": "GIT",
"events": [
{
"introduced": "3fa146678bc6a061722f4ea930998ae29ad70de3"
},
{
"fixed": "bf5b79d5be84c4dad224b61dff0917bebef64114"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:apache:traffic_server:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "10.0.0"
},
{
"fixed": "10.0.4"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"10.0.3-rc1",
"10.0.3",
"10.0.3-rc0",
"10.0.2-rc0",
"10.0.2",
"10.0.1-rc1",
"10.0.1",
"10.0.1-rc0",
"10.0.0-rc0",
"10.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-56196.json"
}
}
],
"modified": "2026-10-28T02:30:24.751440850Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/56xxx/CVE-2024-56196.json",
"https://lists.apache.org/thread/btofzws2yqskk2n7f01r3l1819x01023",
"https://nvd.nist.gov/vuln/detail/CVE-2024-56196"
],
"provider_metadata": {
"cwe_ids": [
"CWE-284"
],
"cna_assigner": "apache",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "10.0.0"
},
{
"last_affected": "10.0.3"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/56xxx/CVE-2024-56196.json"
}
},
"related_cves": [
{
"value": "CVE-2024-56196",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 491557,
"published_at": "2025-03-06T11:21:49.763+00:00"
}