Medium
Security advisory
In Joomla! 1.5.0 through 3.6.5 (fixed in 3.7.0), inadequate filtering of multibyte characters leads to XSS vulnerabilities in various components.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2017-7985
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 07:23 UTC · Revision 1
Source evidence
In Joomla! 1.5.0 through 3.6.5 (fixed in 3.7.0), inadequate filtering of multibyte characters leads to XSS vulnerabilities in various components.
osv:CVE-2017-7985
Complete source record
{
"id": "74aaac277c8d07378cf0e2e468388a7b054b98bb8d34471ee2d27c6c74958833",
"url": "https://osv.dev/vulnerability/CVE-2017-7985",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2017-7985",
"summary": "In Joomla! 1.5.0 through 3.6.5 (fixed in 3.7.0), inadequate filtering of multibyte characters leads to XSS vulnerabilities in various components.",
"evidence": "osv:CVE-2017-7985",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2017-7985",
"aliases": [
"CVE-2017-7985"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/joomla/joomla-cms",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"last_affected": "6a169d998767373c4e0d21ef37ad04d55d67998d"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:joomla:joomla\\!:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "1.5.0"
},
{
"last_affected": "3.6.5"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"3.6.5",
"3.6.4",
"3.6.3",
"3.6.3-rc3",
"3.6.3-rc2",
"3.6.3-rc1",
"3.6.2",
"3.6.1",
"3.6.1-rc2",
"3.6.1-rc1",
"3.6.0",
"3.6.0-rc2",
"3.6.0-rc",
"3.6.0-beta2",
"3.6.0-beta1",
"3.6.0-alpha",
"3.5.1",
"3.5.1-rc2",
"3.5.1-rc",
"3.5.0",
"3.5.0-rc4",
"3.5.0-rc2",
"3.5.0-rc",
"3.5.0-beta5",
"3.5.0-beta4",
"3.5.0-beta3",
"3.5.0-beta2",
"3.4.5",
"3.5.0-beta",
"3.4.4",
"3.4.4-rc2",
"3.4.4-rc",
"3.4.3",
"3.4.2",
"3.4.2-rc",
"3.4.1",
"3.4.1-rc2",
"3.4.1-rc",
"3.4.0",
"3.4.0-rc",
"3.4.0-beta3",
"3.4.0-beta2",
"3.4.0-beta1",
"3.2.4",
"3.3.0",
"3.2.3",
"3.2.2",
"3.2.1",
"3.2.0",
"3.1.5",
"3.2.0.rc",
"3.2.0.beta",
"3.2.0.alpha",
"3.1.1",
"3.0.3",
"3.1.0_beta5",
"3.1.0_beta4",
"3.1.0_beta3",
"3.1.0_beta2",
"3.1.0_beta1",
"3.0.1",
"3.0.0",
"3.0.0_beta1",
"3.0.0_alpha-2",
"3.0.0_alpha-1",
"2.5.6",
"2.5.5",
"2.5.4",
"2.5.1",
"2.5.0",
"2.5.0_beta2",
"2.5.0_beta1",
"1.7.3"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2017-7985.json"
}
}
],
"modified": "2026-10-24T10:30:52.598724271Z",
"provider": "osv",
"references": [
"https://fortiguard.com/zeroday/FG-VD-17-107",
"https://fortiguard.com/zeroday/FG-VD-17-108",
"https://fortiguard.com/zeroday/FG-VD-17-109",
"https://developer.joomla.org/security-centre/685-20170403-core-xss-vulnerability"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2017-7985",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 437747,
"published_at": "2017-04-25T18:59:00.307+00:00"
}