Skip to content
Heist/ feed
Back to feed
Medium

Discourse has insecure default configuration that allows non-admin moderators to takeover any non-staff account via email change

Type: advisorySources: OSV

Discourse is an open source discussion platform. A privilege escalation vulnerability in versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0 allows a non-admin moderator to bypass email-change restrictions, allowing a takeover of non-staff accounts. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. As a workaround, ensure moderators are trusted or enable the "require_change_email_confirmation" setting.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2025-69289
Confirmed fixed CVEs
Not specified
Updated in this feed
3 Nov 2026, 01:12 UTC · Revision 1

Source evidence

Discourse has insecure default configuration that allows non-admin moderators to takeover any non-staff account via email change

core-osv · Original source

Published 28 Jan 2026, 19:33 UTC

Discourse is an open source discussion platform. A privilege escalation vulnerability in versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0 allows a non-admin moderator to bypass email-change restrictions, allowing a takeover of non-staff accounts. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. As a workaround, ensure moderators are trusted or enable the "require_change_email_confirmation" setting.

osv:CVE-2025-69289
Complete source record
{
  "id": "f1622f5a51754541a4c981637acd31b15b0f3688496fa45cf25869de80d70f50",
  "url": "https://osv.dev/vulnerability/CVE-2025-69289",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Discourse has insecure default configuration that allows non-admin moderators to takeover any non-staff account via email change",
    "summary": "Discourse is an open source discussion platform. A privilege escalation vulnerability in versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0 allows a non-admin moderator to bypass email-change restrictions, allowing a takeover of non-staff accounts. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. As a workaround, ensure moderators are trusted or enable the \"require_change_email_confirmation\" setting.",
    "evidence": "osv:CVE-2025-69289",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2025-69289",
      "aliases": [
        "BIT-discourse-2025-69289",
        "CVE-2025-69289",
        "GHSA-p39j-x54c-rwqq"
      ],
      "metrics": [
        {
          "type": "CVSS_V4",
          "score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/discourse/discourse",
              "type": "GIT",
              "events": [
                {
                  "introduced": "75d61b40ee928a4620b16f5438ca886678fab00d"
                },
                {
                  "fixed": "f31b18139a7aadbc4a5f7e8e565a6f4376010c3a"
                },
                {
                  "introduced": "3e7317b3344cca6c6510a32cc4c5c0f540132ad9"
                },
                {
                  "last_affected": "322d3c0ac6a8f133b3f82875e9dbbe310f638c1b"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:discourse:discourse:*:*:*:*:stable:*:*:*",
                    "range": [
                      {
                        "introduced": "2025.11.0"
                      },
                      {
                        "fixed": "2025.11.2"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "cpe": "cpe:2.3:a:discourse:discourse:2025.12.0:*:*:*:stable:*:*:*",
                    "range": [
                      {
                        "introduced": "2025.12.0"
                      },
                      {
                        "last_affected": "2025.12.0"
                      }
                    ],
                    "source": "CPE_STRING"
                  },
                  {
                    "cpe": "cpe:2.3:a:discourse:discourse:2026.1.0:*:*:*:stable:*:*:*",
                    "range": [
                      {
                        "introduced": "2026.1.0"
                      },
                      {
                        "last_affected": "2026.1.0"
                      }
                    ],
                    "source": "CPE_STRING"
                  }
                ]
              }
            }
          ],
          "versions": [
            "2025.12.0",
            "2026.1.0",
            "v2025.11.1",
            "v2026.1.0-latest",
            "v2025.11.0",
            "v2025.12.0-latest"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-69289.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:24.819008275Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/69xxx/CVE-2025-69289.json",
        "https://github.com/discourse/discourse/security/advisories/GHSA-p39j-x54c-rwqq",
        "https://nvd.nist.gov/vuln/detail/CVE-2025-69289"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-863"
        ],
        "cna_assigner": "GitHub_M",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "fixed": "3.5.4"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "StringRangeExpression"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/69xxx/CVE-2025-69289.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2025-69289",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 491454,
  "published_at": "2026-01-28T19:33:58.921+00:00"
}