MediumFix available
mariadb — security advisory
MariaDB Server before 10.3.34 thru 10.9.3 is vulnerable to Denial of Service. It is possible for function spider_db_mbase::print_warnings to dereference a null pointer.
- Products
- mariadb
- Affected versions
- Not specified
- Fixed versions
- 10.6.13-r0
- CVEs
- CVE-2022-47015
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 14:19 UTC · Revision 1
Source evidence
MariaDB Server before 10.3.34 thru 10.9.3 is vulnerable to Denial of Service. It is possible for function spider_db_mbase::print_warnings to dereference a null pointer.
osv:ALPINE-CVE-2022-47015
mariadb
Fixed versions: 10.6.13-r0
mariadb
Fixed versions: 10.6.13-r0
mariadb
Fixed versions: 10.6.13-r0
Complete source record
{
"id": "292901bf27e9ee9fba1f0679a799c3c8d72a9945781d8ce2aa8cef06c2bcdd2f",
"url": "https://osv.dev/vulnerability/ALPINE-CVE-2022-47015",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "ALPINE-CVE-2022-47015",
"summary": "MariaDB Server before 10.3.34 thru 10.9.3 is vulnerable to Denial of Service. It is possible for function spider_db_mbase::print_warnings to dereference a null pointer.",
"evidence": "osv:ALPINE-CVE-2022-47015",
"products": [
{
"name": {
"value": "mariadb",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "10.6.13-r0",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "mariadb",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "10.6.13-r0",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "mariadb",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "10.6.13-r0",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "ALPINE-CVE-2022-47015",
"aliases": [
"ALPINE-CVE-2022-47015"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "10.3.0"
},
{
"fixed": "10.6.13-r0"
}
]
}
],
"package": {
"name": "mariadb",
"purl": "pkg:apk/alpine/mariadb?arch=source",
"ecosystem": "Alpine:v3.15"
},
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2022-47015.json"
},
"ecosystem_specific": {}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "10.3.0"
},
{
"fixed": "10.6.13-r0"
}
]
}
],
"package": {
"name": "mariadb",
"purl": "pkg:apk/alpine/mariadb?arch=source",
"ecosystem": "Alpine:v3.16"
},
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2022-47015.json"
},
"ecosystem_specific": {}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "10.3.0"
},
{
"fixed": "10.6.13-r0"
}
]
}
],
"package": {
"name": "mariadb",
"purl": "pkg:apk/alpine/mariadb?arch=source",
"ecosystem": "Alpine:v3.17"
},
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2022-47015.json"
},
"ecosystem_specific": {}
}
],
"modified": "2026-10-15T07:17:54.275353670Z",
"provider": "osv",
"upstream": [
"CVE-2022-47015"
],
"references": [
"https://security.alpinelinux.org/vuln/CVE-2022-47015"
]
},
"related_cves": [
{
"value": "CVE-2022-47015",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 322059,
"published_at": "2023-01-20T19:15:17.443+00:00"
}