MediumFix available
PSIRT Restricted CLI escape using Lua
Type: patchSources: Fortinet PSIRT
An authenticated administrator may execute Lua scripts through crafted CLI commands in affected FortiOS and FortiProxy versions. The announcement lists upgrade versions that address the issue.
- Products
- FortiOS, FortiProxy
- Affected versions
- 7.2.0 through 7.2.10, 7.2.0 through 7.2.14, 7.4.0 through 7.4.10, 7.4.0 through 7.4.7, 7.6.0 through 7.6.2, 7.6.0 through 7.6.3
- Fixed versions
- 7.2.11 or above, 7.2.15 or above, 7.4.11 or above, 7.4.8 or above, 7.6.3 or above, 7.6.4 or above
- CVEs
- CVE-2025-67862
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 20:43 UTC · Revision 1
Source evidence
PSIRT Restricted CLI escape using Lua
official-fortinet-psirt · Original sourcePublished 9 Jun 2026, 07:00 UTC
An authenticated administrator may execute Lua scripts through crafted CLI commands in affected FortiOS and FortiProxy versions. The announcement lists upgrade versions that address the issue.
may allow an authenticated admin to execute lua scripts via crafted CLI commands.
FortiOS
Fixed versions: 7.6.3 or above, 7.4.8 or above, 7.2.11 or above
Prerequisites: an authenticated admin
FortiProxy
Fixed versions: 7.6.4 or above, 7.4.11 or above, 7.2.15 or above
Prerequisites: an authenticated admin
Complete source record
{
"id": "00b9342eb16ebe31e42263c05498331da0eae4f19f8ca5cb722f441a010c4f34",
"url": "https://fortiguard.fortinet.com/psirt/FG-IR-26-143",
"method": "llm",
"payload": {
"kind": "patch",
"title": "PSIRT Restricted CLI escape using Lua",
"summary": "An authenticated administrator may execute Lua scripts through crafted CLI commands in affected FortiOS and FortiProxy versions. The announcement lists upgrade versions that address the issue.",
"evidence": "may allow an authenticated admin to execute lua scripts via crafted CLI commands.",
"products": [
{
"name": {
"value": "FortiOS",
"evidence": "FortiOS 7.6"
},
"prerequisites": [
{
"value": "an authenticated admin",
"evidence": "may allow an authenticated admin to execute lua scripts via crafted CLI commands"
}
],
"fixed_versions": [
{
"value": "7.6.3 or above",
"evidence": "Upgrade to 7.6.3 or above"
},
{
"value": "7.4.8 or above",
"evidence": "Upgrade to 7.4.8 or above"
},
{
"value": "7.2.11 or above",
"evidence": "Upgrade to 7.2.11 or above"
}
],
"affected_versions": [
{
"value": "7.6.0 through 7.6.2",
"evidence": "7.6.0 through 7.6.2"
},
{
"value": "7.4.0 through 7.4.7",
"evidence": "7.4.0 through 7.4.7"
},
{
"value": "7.2.0 through 7.2.10",
"evidence": "7.2.0 through 7.2.10"
}
]
},
{
"name": {
"value": "FortiProxy",
"evidence": "FortiProxy 7.6"
},
"prerequisites": [
{
"value": "an authenticated admin",
"evidence": "may allow an authenticated admin to execute lua scripts via crafted CLI commands"
}
],
"fixed_versions": [
{
"value": "7.6.4 or above",
"evidence": "Upgrade to 7.6.4 or above"
},
{
"value": "7.4.11 or above",
"evidence": "Upgrade to 7.4.11 or above"
},
{
"value": "7.2.15 or above",
"evidence": "Upgrade to 7.2.15 or above"
}
],
"affected_versions": [
{
"value": "7.6.0 through 7.6.3",
"evidence": "7.6.0 through 7.6.3"
},
{
"value": "7.4.0 through 7.4.10",
"evidence": "7.4.0 through 7.4.10"
},
{
"value": "7.2.0 through 7.2.14",
"evidence": "7.2.0 through 7.2.14"
}
]
}
],
"severity": "medium",
"fixed_cves": [],
"related_cves": [
{
"value": "CVE-2025-67862",
"evidence": "CVE ID CVE-2025-67862"
}
],
"security_relevant": true,
"severity_evidence": "Severity Medium"
},
"source_id": "official-fortinet-psirt",
"document_id": 23594,
"published_at": "2026-06-09T07:00:00+00:00"
}