sharp inherited vulnerabilities in libvips: CVE-2026-33327, CVE-2026-33328, CVE-2026-35590, CVE-2026-35591
### Impact A number of vulnerabilities, two rated as "High" severity using CVSSv4, have been discovered and fixed in the upstream libvips dependency. Those processing untrusted input with versions of sharp prior to 0.35.0 are affected. ### Patches #### Using prebuilt binaries provided by sharp? Most people rely on the prebuilt binaries provided by sharp. Please upgrade sharp to the latest version, currently 0.35.3, which provides libvips 8.18.3. #### Using a globally-installed libvips? Please ensure you are using the latest libvips 8.18.3. ### Workarounds Add the following to your code to prevent sharp from decoding GIF, TIFF and VIPS images. ```js sharp.block({ operation: ["VipsForeignLoadNsgif", "VipsForeignLoadTiff", "VipsForeignLoadVips"] }); ```
- Products
- sharp
- Affected versions
- Not specified
- Fixed versions
- 0.35.0
- CVEs
- CVE-2026-114113
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 14:09 UTC · Revision 1
Source evidence
sharp inherited vulnerabilities in libvips: CVE-2026-33327, CVE-2026-33328, CVE-2026-35590, CVE-2026-35591
core-osv · Original sourcePublished 21 Jul 2026, 22:07 UTC
### Impact A number of vulnerabilities, two rated as "High" severity using CVSSv4, have been discovered and fixed in the upstream libvips dependency. Those processing untrusted input with versions of sharp prior to 0.35.0 are affected. ### Patches #### Using prebuilt binaries provided by sharp? Most people rely on the prebuilt binaries provided by sharp. Please upgrade sharp to the latest version, currently 0.35.3, which provides libvips 8.18.3. #### Using a globally-installed libvips? Please ensure you are using the latest libvips 8.18.3. ### Workarounds Add the following to your code to prevent sharp from decoding GIF, TIFF and VIPS images. ```js sharp.block({ operation: ["VipsForeignLoadNsgif", "VipsForeignLoadTiff", "VipsForeignLoadVips"] }); ```
osv:GHSA-f88m-g3jw-g9cj
sharp
Fixed versions: 0.35.0
Complete source record
{
"id": "75911efbab889aeffec2e10b0761866dbf2af226b9db01c53d81f22b3b830ea5",
"url": "https://osv.dev/vulnerability/GHSA-f88m-g3jw-g9cj",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "sharp inherited vulnerabilities in libvips: CVE-2026-33327, CVE-2026-33328, CVE-2026-35590, CVE-2026-35591",
"summary": "### Impact A number of vulnerabilities, two rated as \"High\" severity using CVSSv4, have been discovered and fixed in the upstream libvips dependency. Those processing untrusted input with versions of sharp prior to 0.35.0 are affected. ### Patches #### Using prebuilt binaries provided by sharp? Most people rely on the prebuilt binaries provided by sharp. Please upgrade sharp to the latest version, currently 0.35.3, which provides libvips 8.18.3. #### Using a globally-installed libvips? Please ensure you are using the latest libvips 8.18.3. ### Workarounds Add the following to your code to prevent sharp from decoding GIF, TIFF and VIPS images. ```js sharp.block({ operation: [\"VipsForeignLoadNsgif\", \"VipsForeignLoadTiff\", \"VipsForeignLoadVips\"] }); ```",
"evidence": "osv:GHSA-f88m-g3jw-g9cj",
"products": [
{
"name": {
"value": "sharp",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "0.35.0",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "GHSA-f88m-g3jw-g9cj",
"aliases": [
"CVE-2026-114113",
"GHSA-f88m-g3jw-g9cj"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:H/SC:N/SI:N/SA:N"
}
],
"affected": [
{
"ranges": [
{
"type": "SEMVER",
"events": [
{
"introduced": "0"
},
{
"fixed": "0.35.0"
}
]
}
],
"package": {
"name": "sharp",
"purl": "pkg:npm/sharp",
"ecosystem": "npm"
},
"database_specific": {
"source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/07/GHSA-f88m-g3jw-g9cj/GHSA-f88m-g3jw-g9cj.json"
}
}
],
"modified": "2026-10-21T10:57:27.250198301Z",
"provider": "osv",
"references": [
"https://github.com/libvips/libvips/security/advisories/GHSA-2fcj-gj27-279x",
"https://github.com/libvips/libvips/security/advisories/GHSA-523x-vhfw-6r76",
"https://github.com/libvips/libvips/security/advisories/GHSA-jmwm-wc68-mhwm",
"https://github.com/libvips/libvips/security/advisories/GHSA-r98w-4fp7-m9c7",
"https://github.com/lovell/sharp/security/advisories/GHSA-f88m-g3jw-g9cj",
"https://github.com/lovell/sharp"
],
"provider_metadata": {
"cwe_ids": [
"CWE-1395"
],
"severity": "HIGH",
"github_reviewed": true,
"nvd_published_at": null,
"github_reviewed_at": "2026-07-21T22:07:17Z"
}
},
"related_cves": [
{
"value": "CVE-2026-114113",
"evidence": "/aliases"
}
],
"security_relevant": true,
"severity_evidence": "/database_specific/severity"
},
"source_id": "core-osv",
"document_id": 392984,
"published_at": "2026-07-21T22:07:17+00:00"
}