Skip to content
Heist/ feed
Back to feed
High

Security advisory

Type: advisorySources: OSVCVE: CVE-2022-42906

powerline-gitstatus (aka Powerline Gitstatus) before 1.3.2 allows arbitrary code execution. git repositories can contain per-repository configuration that changes the behavior of git, including running arbitrary commands. When using powerline-gitstatus, changing to a directory automatically runs git commands in order to display information about the current repository in the prompt. If an attacker can convince a user to change their current directory to one controlled by the attacker, such as in a shared filesystem or extracted archive, powerline-gitstatus will run arbitrary commands under the attacker's control. NOTE: this is similar to CVE-2022-20001.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2022-42906
Confirmed fixed CVEs
Not specified
Updated in this feed
6 Nov 2026, 04:18 UTC · Revision 1

Source evidence

CVE-2022-42906

core-osv · Original source

Published 13 Oct 2022, 00:00 UTC

powerline-gitstatus (aka Powerline Gitstatus) before 1.3.2 allows arbitrary code execution. git repositories can contain per-repository configuration that changes the behavior of git, including running arbitrary commands. When using powerline-gitstatus, changing to a directory automatically runs git commands in order to display information about the current repository in the prompt. If an attacker can convince a user to change their current directory to one controlled by the attacker, such as in a shared filesystem or extracted archive, powerline-gitstatus will run arbitrary commands under the attacker's control. NOTE: this is similar to CVE-2022-20001.

osv:CVE-2022-42906
Complete source record
{
  "id": "e6c7ae56463e650ff4739ba36ed7ced74170360a61c64c51a80bb8f3dffeef60",
  "url": "https://osv.dev/vulnerability/CVE-2022-42906",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2022-42906",
    "summary": "powerline-gitstatus (aka Powerline Gitstatus) before 1.3.2 allows arbitrary code execution. git repositories can contain per-repository configuration that changes the behavior of git, including running arbitrary commands. When using powerline-gitstatus, changing to a directory automatically runs git commands in order to display information about the current repository in the prompt. If an attacker can convince a user to change their current directory to one controlled by the attacker, such as in a shared filesystem or extracted archive, powerline-gitstatus will run arbitrary commands under the attacker's control. NOTE: this is similar to CVE-2022-20001.",
    "evidence": "osv:CVE-2022-42906",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2022-42906",
      "aliases": [
        "CVE-2022-42906",
        "GHSA-w67g-6gjv-c599",
        "PYSEC-2026-898"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/jaspernbrouwer/powerline-gitstatus",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "fe8e963b3489e4cceaa2c1f26f2bcc2ef405364c"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "1.3.2"
                      }
                    ],
                    "source": "DESCRIPTION"
                  },
                  {
                    "range": [
                      {
                        "fixed": "fe8e963b3489e4cceaa2c1f26f2bcc2ef405364c"
                      }
                    ],
                    "source": "REFERENCES_TAG",
                    "original_tag": "v1.3.2"
                  },
                  {
                    "cpe": "cpe:2.3:a:powerline_gitstatus_project:powerline_gitstatus:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "1.3.2"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v1.3.1",
            "v1.3.0",
            "v1.2.1",
            "v1.1.1",
            "v1.1.0",
            "v1.0.4",
            "v1.0.3",
            "v1.0.2",
            "v1.0.1",
            "v1.0.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-42906.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:46.437585674Z",
      "provider": "osv",
      "references": [
        "https://github.com/jaspernbrouwer/powerline-gitstatus/releases/tag/v1.3.2",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/42xxx/CVE-2022-42906.json",
        "https://nvd.nist.gov/vuln/detail/CVE-2022-42906",
        "https://github.com/jaspernbrouwer/powerline-gitstatus/issues/45",
        "https://lists.debian.org/debian-lts-announce/2023/01/msg00017.html"
      ],
      "provider_metadata": {
        "cna_assigner": "mitre",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/42xxx/CVE-2022-42906.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2022-42906",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 514595,
  "published_at": "2022-10-13T00:00:00+00:00"
}