Unrated
Post SMTP < 2.1.4 - Admin+ Stored Cross-Site Scripting
Type: advisorySources: OSV
The Post SMTP Mailer/Email Log WordPress plugin before 2.1.4 does not escape some of its settings before outputting them in the admins dashboard, allowing high privilege users to perform Cross-Site Scripting attacks against other users even when the unfiltered_html capability is disallowed.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-2351
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 18:42 UTC · Revision 1
Source evidence
Post SMTP < 2.1.4 - Admin+ Stored Cross-Site Scripting
core-osv · Original sourcePublished 16 Sept 2022, 08:40 UTC
The Post SMTP Mailer/Email Log WordPress plugin before 2.1.4 does not escape some of its settings before outputting them in the admins dashboard, allowing high privilege users to perform Cross-Site Scripting attacks against other users even when the unfiltered_html capability is disallowed.
osv:CVE-2022-2351
Complete source record
{
"id": "1a1ef2a5b5883c1f3ca8207cf785050af3465b8b5130037c789aa669346355c4",
"url": "https://osv.dev/vulnerability/CVE-2022-2351",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Post SMTP < 2.1.4 - Admin+ Stored Cross-Site Scripting",
"summary": "The Post SMTP Mailer/Email Log WordPress plugin before 2.1.4 does not escape some of its settings before outputting them in the admins dashboard, allowing high privilege users to perform Cross-Site Scripting attacks against other users even when the unfiltered_html capability is disallowed.",
"evidence": "osv:CVE-2022-2351",
"products": [],
"severity": "unknown",
"structured": {
"id": "CVE-2022-2351",
"aliases": [
"CVE-2022-2351"
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/wpexpertsio/post-smtp",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "315ba4588beefdecc2ae9c5e6d5ac4672f760f21"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:wpexperts:post_smtp:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.1.4"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"2.1.4-rc.2",
"2.1.4-rc.1",
"2.1.4-beta.1",
"2.1.2",
"2.1.2-rc.2",
"2.1.2-rc.1",
"2.1.2-beta-1",
"2.1.1.1",
"2.1.1",
"2.1",
"2.1-beta.1",
"2.0.27",
"2.0.26",
"2.0.25-beta.1",
"2.0.25",
"2.0.24",
"2.0.23",
"2.0.22",
"2.0.21",
"2.0.20",
"2.0.19",
"2.0.18",
"2.0.17",
"2.0.16",
"2.0.15",
"2.0.14",
"2.0.13",
"2.0.12",
"2.0.11",
"2.0.10",
"2.0.9",
"2.0.8",
"2.0.7",
"2.0.6",
"2.0.5",
"2.0.4",
"2.0.3",
"2.0.2",
"2.0.1",
"v1.9.8",
"v1.9.7",
"v1.9.6",
"v1.9.5",
"v1.9.4",
"v1.9.3",
"v.1.9.2",
"v.1.9.1",
"v.1.9.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-2351.json"
}
}
],
"modified": "2026-10-28T02:30:38.244184195Z",
"provider": "osv",
"references": [
"https://wpscan.com/vulnerability/f3fda033-58f5-446d-ade4-2336a39bfb87",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/2xxx/CVE-2022-2351.json",
"https://nvd.nist.gov/vuln/detail/CVE-2022-2351"
],
"provider_metadata": {
"cwe_ids": [
"CWE-79"
],
"cna_assigner": "WPScan",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "2.1.4"
},
{
"last_affected": "2.1.4"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/2xxx/CVE-2022-2351.json"
}
},
"related_cves": [
{
"value": "CVE-2022-2351",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 505798,
"published_at": "2022-09-16T08:40:27+00:00"
}