NetworkManager-l2tp Privilege Escalation via pppd Username Injection
NetworkManager-l2tp through 1.52.4, fixed in 1.52.6, contains a privilege escalation vulnerability that allows local users with permission to create VPN connections to execute arbitrary code as root by injecting pppd options through a crafted VPN username. Attackers can embed a double-quote character or whitespace in the username to break out of the pppd options file quoting context and include the pppd plugin directive, causing the privileged pppd process to load an attacker-controlled shared object.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-75131
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 4 Nov 2026, 09:08 UTC · Revision 1
Source evidence
NetworkManager-l2tp Privilege Escalation via pppd Username Injection
core-osv · Original sourcePublished 23 Sept 2026, 18:09 UTC
NetworkManager-l2tp through 1.52.4, fixed in 1.52.6, contains a privilege escalation vulnerability that allows local users with permission to create VPN connections to execute arbitrary code as root by injecting pppd options through a crafted VPN username. Attackers can embed a double-quote character or whitespace in the username to break out of the pppd options file quoting context and include the pppd plugin directive, causing the privileged pppd process to load an attacker-controlled shared object.
osv:CVE-2026-75131
Complete source record
{
"id": "fc3ab452899b799c363ad081b69737dbf10a81ae56bc7d7c4dd6c174e7baf78b",
"url": "https://osv.dev/vulnerability/CVE-2026-75131",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "NetworkManager-l2tp Privilege Escalation via pppd Username Injection",
"summary": "NetworkManager-l2tp through 1.52.4, fixed in 1.52.6, contains a privilege escalation vulnerability that allows local users with permission to create VPN connections to execute arbitrary code as root by injecting pppd options through a crafted VPN username. Attackers can embed a double-quote character or whitespace in the username to break out of the pppd options file quoting context and include the pppd plugin directive, causing the privileged pppd process to load an attacker-controlled shared object.",
"evidence": "osv:CVE-2026-75131",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2026-75131",
"aliases": [
"CVE-2026-75131",
"GHSA-v2wj-xr2m-xc4j"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/nm-l2tp/networkmanager-l2tp",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "116a35a934ed6b5567302593116bf91f709bacb5"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "2tp"
},
{
"last_affected": "1.52.4"
}
],
"source": "DESCRIPTION"
},
{
"range": [
{
"introduced": "0"
},
{
"fixed": "1.52.6"
}
],
"source": "DESCRIPTION"
}
]
}
}
],
"versions": [
"1.52.4",
"1.20.22",
"1.52.2",
"1.52.0",
"1.20.20",
"1.20.18",
"1.20.16",
"1.20.14",
"1.20.12",
"1.20.10",
"1.20.8",
"1.20.6",
"1.20.4",
"1.8.6",
"1.20.2",
"1.20.0",
"1.8.4",
"1.8.2",
"1.8.0",
"1.2.8",
"1.2.6",
"1.2.4",
"0.9.8.7",
"0.9.8.6",
"0.9.8.5",
"0.9.8.4",
"0.9.8",
"0.9.6",
"0.9.4",
"0.3.3",
"0.3.2",
"0.3.1",
"0.3.0",
"0.2",
"0.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-75131.json"
}
}
],
"modified": "2026-10-28T02:30:34.391863780Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/75xxx/CVE-2026-75131.json",
"https://github.com/nm-l2tp/NetworkManager-l2tp/security/advisories/GHSA-v2wj-xr2m-xc4j",
"https://nvd.nist.gov/vuln/detail/CVE-2026-75131",
"https://www.vulncheck.com/advisories/networkmanager-l2tp-privilege-escalation-via-pppd-username-injection",
"https://github.com/nm-l2tp/NetworkManager-l2tp"
],
"provider_metadata": {
"cwe_ids": [
"CWE-88"
],
"cna_assigner": "VulnCheck",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/75xxx/CVE-2026-75131.json"
}
},
"related_cves": [
{
"value": "CVE-2026-75131",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 501324,
"published_at": "2026-09-23T18:09:07.111+00:00"
}