Skip to content
Heist/ feed
Back to feed
High

OpenSTAManager has an authenticated SQL Injection vulnerability in API via 'display' parameter

Type: advisorySources: OSV

OpenSTAManager is an open source management software for technical assistance and invoicing. Prior to version 2.9.5, an authenticated SQL Injection vulnerability in the API allows any user, regardless of permission level, to execute arbitrary SQL queries. By manipulating the display parameter in an API request, an attacker can exfiltrate, modify, or delete any data in the database, leading to a full system compromise. This issue has been patched in version 2.9.5.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2025-65103
Confirmed fixed CVEs
Not specified
Updated in this feed
3 Nov 2026, 01:24 UTC · Revision 1

Source evidence

OpenSTAManager has an authenticated SQL Injection vulnerability in API via 'display' parameter

core-osv · Original source

Published 19 Nov 2025, 19:09 UTC

OpenSTAManager is an open source management software for technical assistance and invoicing. Prior to version 2.9.5, an authenticated SQL Injection vulnerability in the API allows any user, regardless of permission level, to execute arbitrary SQL queries. By manipulating the display parameter in an API request, an attacker can exfiltrate, modify, or delete any data in the database, leading to a full system compromise. This issue has been patched in version 2.9.5.

osv:CVE-2025-65103
Complete source record
{
  "id": "b17956135f0dacba912304a43f069905ad785213a2f18a5313c6ad8b2b636f21",
  "url": "https://osv.dev/vulnerability/CVE-2025-65103",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "OpenSTAManager has an authenticated SQL Injection vulnerability in API via 'display' parameter",
    "summary": "OpenSTAManager is an open source management software for technical assistance and invoicing. Prior to version 2.9.5, an authenticated SQL Injection vulnerability in the API allows any user, regardless of permission level, to execute arbitrary SQL queries. By manipulating the display parameter in an API request, an attacker can exfiltrate, modify, or delete any data in the database, leading to a full system compromise. This issue has been patched in version 2.9.5.",
    "evidence": "osv:CVE-2025-65103",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2025-65103",
      "aliases": [
        "CVE-2025-65103",
        "GHSA-2jm2-2p35-rp3j"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/devcode-it/openstamanager",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "b44cf1388d1f2d17f6703975c36d971e66d91ce0"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "2.9.5"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StringRangeExpression"
                  },
                  {
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "2.9.5"
                      }
                    ],
                    "source": "DESCRIPTION"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v2.9.4",
            "v2.9.3",
            "v2.9.2",
            "v2.9-beta",
            "v2.9",
            "v2.6.2",
            "v2.6.1",
            "v2.5.5",
            "v2.5.4",
            "v2.5.3",
            "v2.5.2-beta",
            "v2.5.1-beta",
            "v2.5",
            "v2.4.54",
            "v2.4.53",
            "v2.4.51",
            "v2.4.49",
            "v2.4.47",
            "v2.4.44",
            "v2.4.43",
            "v2.4.42",
            "v2.4.41",
            "v2.4.40",
            "v2.4.38",
            "v2.4.32",
            "v2.4.28",
            "v2.4.25",
            "v2.4.24",
            "v2.4.23",
            "v2.4.22",
            "v2.4.20",
            "v2.4.17",
            "v2.4.16",
            "v2.4.14",
            "v2.4.13",
            "v2.4.12",
            "v2.4.11",
            "v2.4.10",
            "v2.4.9",
            "v2.4.8",
            "v2.4.6",
            "v2.4.4",
            "v2.4.3",
            "v2.4.2",
            "v2.4",
            "v2.3-beta.2",
            "v2.3-beta.1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-65103.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:24.869800902Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/65xxx/CVE-2025-65103.json",
        "https://github.com/devcode-it/openstamanager/security/advisories/GHSA-2jm2-2p35-rp3j",
        "https://nvd.nist.gov/vuln/detail/CVE-2025-65103"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-89"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/65xxx/CVE-2025-65103.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2025-65103",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 491599,
  "published_at": "2025-11-19T19:09:09.209+00:00"
}