Medium
LifterLMS – WP LMS for eLearning, Online Courses, & Quizzes <= 7.8.5 - Missing Authorization to Authenticated (Subscriber+) Arbitrary Post Deletion
Type: advisorySources: OSV
The LifterLMS – WP LMS for eLearning, Online Courses, & Quizzes plugin for WordPress is vulnerable to arbitrary post deletion due to a missing capability check on the 'llms_delete_cert' action in all versions up to, and including, 7.8.5. This makes it possible for authenticated attackers, with Subscriber-level access and above, to delete arbitrary posts.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2024-12596
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 10:26 UTC · Revision 1
Source evidence
LifterLMS – WP LMS for eLearning, Online Courses, & Quizzes <= 7.8.5 - Missing Authorization to Authenticated (Subscriber+) Arbitrary Post Deletion
core-osv · Original sourcePublished 18 Dec 2024, 03:22 UTC
The LifterLMS – WP LMS for eLearning, Online Courses, & Quizzes plugin for WordPress is vulnerable to arbitrary post deletion due to a missing capability check on the 'llms_delete_cert' action in all versions up to, and including, 7.8.5. This makes it possible for authenticated attackers, with Subscriber-level access and above, to delete arbitrary posts.
osv:CVE-2024-12596
Complete source record
{
"id": "0126a2bb5d148e560093354e328308aeb22792cf2f80887e9872b630a4b2a748",
"url": "https://osv.dev/vulnerability/CVE-2024-12596",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "LifterLMS – WP LMS for eLearning, Online Courses, & Quizzes <= 7.8.5 - Missing Authorization to Authenticated (Subscriber+) Arbitrary Post Deletion",
"summary": "The LifterLMS – WP LMS for eLearning, Online Courses, & Quizzes plugin for WordPress is vulnerable to arbitrary post deletion due to a missing capability check on the 'llms_delete_cert' action in all versions up to, and including, 7.8.5. This makes it possible for authenticated attackers, with Subscriber-level access and above, to delete arbitrary posts.",
"evidence": "osv:CVE-2024-12596",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2024-12596",
"aliases": [
"CVE-2024-12596"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/gocodebox/lifterlms",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "51217f61961dc29a1557cd18f0307b9b6db4289d"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:lifterlms:lifterlms:*:*:*:*:*:wordpress:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "7.8.6"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"@lifterlms/scripts@2.2.0",
"@lifterlms/llms-e2e-test-utils@3.2.0",
"@lifterlms/dev@0.0.4-alpha.0",
"@lifterlms/brand@0.0.2",
"@lifterlms/scripts@1.3.7",
"@lifterlms/llms-e2e-test-utils@2.2.3",
"@lifterlms/brand@0.0.1",
"@lifterlms/scripts@1.3.5",
"@lifterlms/llms-e2e-test-utils@2.2.2",
"@lifterlms/llms-e2e-test-utils@2.1.3",
"@lifterlms/scripts@1.3.2",
"@lifterlms/scripts@1.3.0",
"@lifterlms/scripts@1.2.4",
"@lifterlms/scripts@1.2.3",
"@lifterlms/llms-e2e-test-utils@2.1.2",
"@lifterlms/scripts@1.2.1",
"@lifterlms/llms-e2e-test-utils@2.1.0",
"@lifterlms/scripts@1.3.1",
"@lifterlms/scripts@1.2.0",
"@lifterlms/llms-e2e-test-utils@2.0.0",
"@lifterlms/llms-e2e-test-utils@1.1.1",
"llms-e2e-test-utils@1.1.0",
"llms-e2e-test-utils@1.0.1",
"llms-e2e-test-utils@1.0.0",
"3.20.0-beta.1",
"3.0.0-beta.5",
"3.0.0-beta.4",
"3.0.0-beta.3",
"3.0.0-beta.2",
"3.0.0-beta.1",
"1.4.0",
"1.3.10",
"1.3.9",
"1.3.8",
"1.3.7",
"1.3.6",
"1.3.5",
"1.3.4",
"v1.3.3",
"1.3.2",
"1.3.0",
"1.2.6",
"1.2.5",
"1.2.4",
"1.1.1",
"1.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-12596.json"
}
}
],
"modified": "2026-10-28T02:30:27.872423122Z",
"provider": "osv",
"references": [
"https://plugins.trac.wordpress.org/changeset/3208662/lifterlms/trunk/includes/abstracts/llms-abstract-controller-user-engagements.php",
"https://plugins.trac.wordpress.org/changeset/3208662/lifterlms/trunk/includes/controllers/class.llms.controller.certificates.php",
"https://www.wordfence.com/threat-intel/vulnerabilities/id/8e75a03b-7552-4228-a4d0-13c78d20f6d5?source=cve",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/12xxx/CVE-2024-12596.json",
"https://nvd.nist.gov/vuln/detail/CVE-2024-12596"
],
"provider_metadata": {
"cwe_ids": [
"CWE-862"
],
"cna_assigner": "Wordfence",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"last_affected": "7.8.5"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/12xxx/CVE-2024-12596.json"
}
},
"related_cves": [
{
"value": "CVE-2024-12596",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 494504,
"published_at": "2024-12-18T03:22:06.256+00:00"
}