High
Authentication Bypass by Capture-replay in packbackbooks/lti-1-3-php-library
Type: advisorySources: OSV
LTI 1.3 Tool Library is a library used for building IMS-certified LTI 1.3 tool providers in PHP. Prior to version 5.0, the Nonce Claim Value was not being validated against the nonce value sent in the Authentication Request. Users should upgrade to version 5.0 to receive a patch. There are currently no known workarounds.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-31158
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 6 Nov 2026, 04:18 UTC · Revision 1
Source evidence
Authentication Bypass by Capture-replay in packbackbooks/lti-1-3-php-library
core-osv · Original sourcePublished 15 Jul 2022, 17:15 UTC
LTI 1.3 Tool Library is a library used for building IMS-certified LTI 1.3 tool providers in PHP. Prior to version 5.0, the Nonce Claim Value was not being validated against the nonce value sent in the Authentication Request. Users should upgrade to version 5.0 to receive a patch. There are currently no known workarounds.
osv:CVE-2022-31158
Complete source record
{
"id": "80ebddcf477850ffd0e0e585677f516d20f4950e76e0539090482606f83495f1",
"url": "https://osv.dev/vulnerability/CVE-2022-31158",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "Authentication Bypass by Capture-replay in packbackbooks/lti-1-3-php-library",
"summary": "LTI 1.3 Tool Library is a library used for building IMS-certified LTI 1.3 tool providers in PHP. Prior to version 5.0, the Nonce Claim Value was not being validated against the nonce value sent in the Authentication Request. Users should upgrade to version 5.0 to receive a patch. There are currently no known workarounds.",
"evidence": "osv:CVE-2022-31158",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2022-31158",
"aliases": [
"CVE-2022-31158",
"GHSA-5p73-qg2v-383h"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/packbackbooks/lti-1-3-php-library",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "0edb00f618aae4630db20cab6cf921fbc8ce4a34"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "0"
},
{
"fixed": "5.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StringRangeExpression"
},
{
"cpe": "cpe:2.3:a:packback:lti_1.3_tool_library:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "5.0.0"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v4.1.3",
"v4.1.2",
"v4.1.1",
"v4.1.0",
"v4.0.0",
"v3.0.3",
"v3.0.2",
"v3.0.1",
"v3.0.0",
"v2.0.3",
"v2.0.2",
"v2.0.1",
"v2.0.0",
"v1.1.1",
"v1.1.0",
"v1.0.0",
"v1.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-31158.json"
}
}
],
"modified": "2026-10-28T02:30:46.797587637Z",
"provider": "osv",
"references": [
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/31xxx/CVE-2022-31158.json",
"https://github.com/packbackbooks/lti-1-3-php-library/security/advisories/GHSA-5p73-qg2v-383h",
"https://nvd.nist.gov/vuln/detail/CVE-2022-31158"
],
"provider_metadata": {
"cwe_ids": [
"CWE-294"
],
"cna_assigner": "GitHub_M",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/31xxx/CVE-2022-31158.json"
}
},
"related_cves": [
{
"value": "CVE-2022-31158",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 514596,
"published_at": "2022-07-15T17:15:12+00:00"
}