HighFix available
squid — security advisory
A buffer over-read was discovered in libntlmauth in Squid 2.5 through 5.6. Due to incorrect integer-overflow protection, the SSPI and SMB authentication helpers are vulnerable to reading unintended memory locations. In some configurations, cleartext credentials from these locations are sent to a client. This is fixed in 5.7.
- Products
- squid
- Affected versions
- Not specified
- Fixed versions
- 5.2-r1
- CVEs
- CVE-2022-41318
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 14:17 UTC · Revision 1
Source evidence
A buffer over-read was discovered in libntlmauth in Squid 2.5 through 5.6. Due to incorrect integer-overflow protection, the SSPI and SMB authentication helpers are vulnerable to reading unintended memory locations. In some configurations, cleartext credentials from these locations are sent to a client. This is fixed in 5.7.
osv:ALPINE-CVE-2022-41318
squid
Fixed versions: 5.2-r1
squid
Fixed versions: 5.2-r1
Complete source record
{
"id": "c2381225a1cec57e61aa3e63c2f78d92233e4401a971fb4eeed6878c8412ea66",
"url": "https://osv.dev/vulnerability/ALPINE-CVE-2022-41318",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "ALPINE-CVE-2022-41318",
"summary": "A buffer over-read was discovered in libntlmauth in Squid 2.5 through 5.6. Due to incorrect integer-overflow protection, the SSPI and SMB authentication helpers are vulnerable to reading unintended memory locations. In some configurations, cleartext credentials from these locations are sent to a client. This is fixed in 5.7.",
"evidence": "osv:ALPINE-CVE-2022-41318",
"products": [
{
"name": {
"value": "squid",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "5.2-r1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "squid",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "5.2-r1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "ALPINE-CVE-2022-41318",
"aliases": [
"ALPINE-CVE-2022-41318"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "2.5"
},
{
"fixed": "5.2-r1"
}
]
}
],
"package": {
"name": "squid",
"purl": "pkg:apk/alpine/squid?arch=source",
"ecosystem": "Alpine:v3.15"
},
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2022-41318.json"
},
"ecosystem_specific": {}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "2.5"
},
{
"fixed": "5.2-r1"
}
]
}
],
"package": {
"name": "squid",
"purl": "pkg:apk/alpine/squid?arch=source",
"ecosystem": "Alpine:v3.16"
},
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/alpine/ALPINE-CVE-2022-41318.json"
},
"ecosystem_specific": {}
}
],
"modified": "2026-10-15T07:17:54.250430424Z",
"provider": "osv",
"upstream": [
"CVE-2022-41318"
],
"references": [
"https://security.alpinelinux.org/vuln/CVE-2022-41318"
]
},
"related_cves": [
{
"value": "CVE-2022-41318",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 321963,
"published_at": "2022-12-25T19:15:10.82+00:00"
}