Skip to content
Heist/ feed
Back to feed
High

Apache Tomcat: APR/Native Connector crash leading to DoS

Type: advisorySources: OSV

Concurrent Execution using Shared Resource with Improper Synchronization ('Race Condition') vulnerability in Apache Tomcat when using the APR/Native connector. This was particularly noticeable with client initiated closes of HTTP/2 connections. This issue affects Apache Tomcat: from 9.0.0.M1 through 9.0.106. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 9.0.107, which fixes the issue.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2025-52434
Confirmed fixed CVEs
Not specified
Updated in this feed
6 Nov 2026, 00:29 UTC · Revision 1

Source evidence

Apache Tomcat: APR/Native Connector crash leading to DoS

core-osv · Original source

Published 10 Jul 2025, 19:03 UTC

Concurrent Execution using Shared Resource with Improper Synchronization ('Race Condition') vulnerability in Apache Tomcat when using the APR/Native connector. This was particularly noticeable with client initiated closes of HTTP/2 connections. This issue affects Apache Tomcat: from 9.0.0.M1 through 9.0.106. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 9.0.107, which fixes the issue.

osv:CVE-2025-52434
Complete source record
{
  "id": "69414ea067623a6458b3fef011d765d84ca186c6045ba5089016a0f293b4a4e4",
  "url": "https://osv.dev/vulnerability/CVE-2025-52434",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Apache Tomcat: APR/Native Connector crash leading to DoS",
    "summary": "Concurrent Execution using Shared Resource with Improper Synchronization ('Race Condition') vulnerability in Apache Tomcat when using the APR/Native connector. This was particularly noticeable with client initiated closes of HTTP/2 connections. This issue affects Apache Tomcat: from 9.0.0.M1 through 9.0.106. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 through 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 9.0.107, which fixes the issue.",
    "evidence": "osv:CVE-2025-52434",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2025-52434",
      "aliases": [
        "BIT-tomcat-2025-52434",
        "CVE-2025-52434",
        "GHSA-4j3c-42xv-3f84"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/apache/tomcat",
              "type": "GIT",
              "events": [
                {
                  "introduced": "16bf392c67833ad549733b58c350ff92b5ee782a"
                },
                {
                  "fixed": "43d5ad023d2eee2ca162eded597a23afa0b92296"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "9.0.0"
                      },
                      {
                        "fixed": "9.0.107"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-52434.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:45.434684159Z",
      "provider": "osv",
      "references": [
        "https://lists.debian.org/debian-lts-announce/2025/07/msg00009.html",
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/52xxx/CVE-2025-52434.json",
        "https://lists.apache.org/thread/gxgh65004f25y8519coth6w7vchww030",
        "https://nvd.nist.gov/vuln/detail/CVE-2025-52434"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-362"
        ],
        "cna_assigner": "apache",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "introduced": "9.0.0.M1"
                  },
                  {
                    "last_affected": "9.0.106"
                  },
                  {
                    "introduced": "8.5.0"
                  },
                  {
                    "last_affected": "8.5.100"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "StandardRange"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/52xxx/CVE-2025-52434.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2025-52434",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 513487,
  "published_at": "2025-07-10T19:03:47.225+00:00"
}