Skip to content
Heist/ feed
Back to feed
MediumFix available

qemu — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2021-3608

A flaw was found in the QEMU implementation of VMWare's paravirtual RDMA device in versions prior to 6.1.0. The issue occurs while handling a "PVRDMA_REG_DSRHIGH" write from the guest and may result in a crash of QEMU or cause undefined behavior due to the access of an uninitialized pointer. The highest threat from this vulnerability is to system availability.

Products
qemu
Affected versions
Not specified
Fixed versions
1:5.2+dfsg-11
CVEs
CVE-2021-3608
Confirmed fixed CVEs
Not specified
Updated in this feed
1 Nov 2026, 00:36 UTC · Revision 1

Source evidence

DEBIAN-CVE-2021-3608

core-osv · Original source

Published 24 Feb 2022, 19:15 UTC

A flaw was found in the QEMU implementation of VMWare's paravirtual RDMA device in versions prior to 6.1.0. The issue occurs while handling a "PVRDMA_REG_DSRHIGH" write from the guest and may result in a crash of QEMU or cause undefined behavior due to the access of an uninitialized pointer. The highest threat from this vulnerability is to system availability.

osv:DEBIAN-CVE-2021-3608

qemu

Fixed versions: 1:5.2+dfsg-11

qemu

Fixed versions: 1:5.2+dfsg-11

qemu

Fixed versions: 1:5.2+dfsg-11

Complete source record
{
  "id": "6d9d6f6acd634e16dd4126971b65da6ccc05bf038167fe78d968c9cb8453e36d",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2021-3608",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2021-3608",
    "summary": "A flaw was found in the QEMU implementation of VMWare's paravirtual RDMA device in versions prior to 6.1.0. The issue occurs while handling a \"PVRDMA_REG_DSRHIGH\" write from the guest and may result in a crash of QEMU or cause undefined behavior due to the access of an uninitialized pointer. The highest threat from this vulnerability is to system availability.",
    "evidence": "osv:DEBIAN-CVE-2021-3608",
    "products": [
      {
        "name": {
          "value": "qemu",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1:5.2+dfsg-11",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "qemu",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1:5.2+dfsg-11",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "qemu",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1:5.2+dfsg-11",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "medium",
    "structured": {
      "id": "DEBIAN-CVE-2021-3608",
      "aliases": [
        "DEBIAN-CVE-2021-3608"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:N/I:N/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1:5.2+dfsg-11"
                }
              ]
            }
          ],
          "package": {
            "name": "qemu",
            "purl": "pkg:deb/debian/qemu?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-3608.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1:5.2+dfsg-11"
                }
              ]
            }
          ],
          "package": {
            "name": "qemu",
            "purl": "pkg:deb/debian/qemu?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-3608.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1:5.2+dfsg-11"
                }
              ]
            }
          ],
          "package": {
            "name": "qemu",
            "purl": "pkg:deb/debian/qemu?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2021-3608.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-23T18:03:29.545448464Z",
      "provider": "osv",
      "upstream": [
        "CVE-2021-3608"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2021-3608"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2021-3608",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 421677,
  "published_at": "2022-02-24T19:15:09.167+00:00"
}