Security advisory
A denial of service vulnerability in the Range header parsing component of Rack >= 1.5.0. A Carefully crafted input can cause the Range header parsing component in Rack to take an unexpected amount of time, possibly resulting in a denial of service attack vector. Any applications that deal with Range requests (such as streaming applications, or applications that serve files) may be impacted.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2022-44570
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 23:18 UTC · Revision 1
Source evidence
A denial of service vulnerability in the Range header parsing component of Rack >= 1.5.0. A Carefully crafted input can cause the Range header parsing component in Rack to take an unexpected amount of time, possibly resulting in a denial of service attack vector. Any applications that deal with Range requests (such as streaming applications, or applications that serve files) may be impacted.
osv:CVE-2022-44570
Complete source record
{
"id": "32afd802f3cec23c818b291ebaf4b64eee1794c2370176b2ca86878ff7772197",
"url": "https://osv.dev/vulnerability/CVE-2022-44570",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2022-44570",
"summary": "A denial of service vulnerability in the Range header parsing component of Rack >= 1.5.0. A Carefully crafted input can cause the Range header parsing component in Rack to take an unexpected amount of time, possibly resulting in a denial of service attack vector. Any applications that deal with Range requests (such as streaming applications, or applications that serve files) may be impacted.",
"evidence": "osv:CVE-2022-44570",
"products": [],
"severity": "unknown",
"structured": {
"id": "CVE-2022-44570",
"aliases": [
"CVE-2022-44570",
"GHSA-65f5-mfpf-vfhj"
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/rack/rack",
"type": "GIT",
"events": [
{
"introduced": "0cba6a4d5aeb1ac8768b6ca36320731487fb596b"
},
{
"fixed": "d573159067d8dc64db97beff67621654754e86f2"
},
{
"introduced": "879ae7163a399a9ed36d876668f4ecae4ae8b9e4"
},
{
"fixed": "8b8efd9591876cb6d40b3120388a8b9a0e083777"
},
{
"introduced": "39d501a28c1fe51284addfe6dacffafb69d49849"
},
{
"fixed": "20bc90c2431d7fabcd1873410543cf3d72f65004"
},
{
"introduced": "52901caf09ebcda879512a8605059963a49df55d"
},
{
"fixed": "d1b4c2d82ac5444228d30e66f38156f7046b4296"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:rack:rack:*:*:*:*:*:ruby:*:*",
"range": [
{
"introduced": "1.5.0"
},
{
"fixed": "2.0.9.2"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:rack:rack:*:*:*:*:*:ruby:*:*",
"range": [
{
"introduced": "2.1.0"
},
{
"fixed": "2.1.4.2"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:rack:rack:*:*:*:*:*:ruby:*:*",
"range": [
{
"introduced": "2.2.0"
},
{
"fixed": "2.2.6.1"
}
],
"source": "CPE_RANGE"
},
{
"cpe": "cpe:2.3:a:rack:rack:*:*:*:*:*:ruby:*:*",
"range": [
{
"introduced": "3.0.0"
},
{
"fixed": "3.0.4.1"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"2.0.9.1",
"v2.2.6",
"v3.0.4",
"v3.0.3",
"v2.2.5",
"2.2.4",
"v3.0.2",
"v3.0.1",
"3.0.0",
"2.1.4",
"2.0.9",
"2.2.3",
"v2.2.2",
"2.1.3",
"2.1.2",
"v2.2.1",
"2.2.0",
"2.1.1",
"2.0.8",
"2.1.0",
"2.0.7",
"2.0.6",
"2.0.4",
"2.0.3",
"2.0.2",
"2.0.1",
"2.0.0",
"2.0.0.rc1",
"2.0.0.alpha",
"1.6.0.beta",
"1.5.1",
"1.5.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-44570.json"
}
}
],
"modified": "2026-10-28T02:30:32.147344343Z",
"provider": "osv",
"references": [
"https://discuss.rubyonrails.org/t/cve-2022-44570-possible-denial-of-service-vulnerability-in-racks-range-header-parsing/82125",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/44xxx/CVE-2022-44570.json",
"https://nvd.nist.gov/vuln/detail/CVE-2022-44570",
"https://security.netapp.com/advisory/ntap-20231208-0010/",
"https://www.debian.org/security/2023/dsa-5530"
],
"provider_metadata": {
"cwe_ids": [
"CWE-400"
],
"cna_assigner": "hackerone",
"unresolved_ranges": [
{
"extracted_events": [
{
"range": [
{
"introduced": "2.0.9.2, 2.1.4.2, 2.2.4.2, 3.0.0.1"
},
{
"last_affected": "2.0.9.2, 2.1.4.2, 2.2.4.2, 3.0.0.1"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
}
]
}
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/44xxx/CVE-2022-44570.json"
}
},
"related_cves": [
{
"value": "CVE-2022-44570",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": null
},
"source_id": "core-osv",
"document_id": 499241,
"published_at": "2023-02-09T00:00:00+00:00"
}