Medium
Security advisory
Nextcloud Desktop Client before 3.3.1 is vulnerable to improper certificate validation due to lack of SSL certificate verification when using the "Register with a Provider" flow.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2021-22895
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 31 Oct 2026, 11:39 UTC · Revision 1
Source evidence
Nextcloud Desktop Client before 3.3.1 is vulnerable to improper certificate validation due to lack of SSL certificate verification when using the "Register with a Provider" flow.
osv:CVE-2021-22895
Complete source record
{
"id": "4474b856ea223c94282abb9a1d569e95ff28851d4ee942fbf1750538f6359ee0",
"url": "https://osv.dev/vulnerability/CVE-2021-22895",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2021-22895",
"summary": "Nextcloud Desktop Client before 3.3.1 is vulnerable to improper certificate validation due to lack of SSL certificate verification when using the \"Register with a Provider\" flow.",
"evidence": "osv:CVE-2021-22895",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2021-22895",
"aliases": [
"CVE-2021-22895",
"GHSA-qpgp-vf4p-wcw5"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/nextcloud/desktop",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "3842d306f950f631482d29466b52667eb2073f1f"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:nextcloud:desktop:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "3.1.3"
}
],
"source": "CPE_RANGE"
},
{
"range": [
{
"fixed": "3842d306f950f631482d29466b52667eb2073f1f"
}
],
"source": "REFERENCES_TAG",
"original_tag": "v3.1.3"
}
]
}
}
],
"versions": [
"v3.1.2",
"v3.1.1",
"v3.1.0",
"v3.1.0-rc2",
"v3.1.0-rc1",
"v2.7.0-rc1",
"v2.7.0-beta3",
"v2.7.0-beta2",
"v2.7.0-beta1",
"v2.5.3-rc2",
"v2.5.3-rc1",
"v2.5.2",
"v2.5.2-rc1",
"v2.5.1",
"v2.5.0",
"v2.5.0-rc2",
"v2.5.0-rc1",
"v2.5.0-beta2",
"v2.5.0-beta1",
"v1.8.0-beta1a",
"v1.8.0-beta1",
"v1.6.0",
"v1.6.0-rc3",
"v1.6.0-rc2",
"v1.6.0-rc1",
"v1.6.0-beta2",
"v1.6.0-beta1",
"v1.5.1-rc1",
"v1.5.0",
"v1.5.0-beta3",
"v1.5.0-beta1-2nd",
"v1.5.0-beta2",
"v1.5.0-beta1",
"v1.4.0",
"v1.4.0-rc1",
"v1.4.0-beta2",
"v1.4.0-beta1",
"v1.3.0-beta3",
"v1.3.0-beta2",
"v1.3.0-beta1",
"v1.2.5",
"v1.2.4",
"v1.2.3",
"v1.2.2",
"v1.2.1",
"v1.2.0",
"v1.1.2",
"v1.1.0",
"v1.1.0-beta1",
"v0.0.2"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-22895.json"
}
}
],
"modified": "2026-10-20T10:54:31.258403572Z",
"provider": "osv",
"references": [
"https://github.com/nextcloud/desktop/releases/tag/v3.1.3",
"https://github.com/nextcloud/security-advisories/security/advisories/GHSA-qpgp-vf4p-wcw5",
"https://www.debian.org/security/2021/dsa-4974",
"https://hackerone.com/reports/903424",
"https://github.com/nextcloud/desktop/pull/2926"
],
"provider_metadata": {
"unresolved_ranges": [
{
"cpes": [
"cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:*",
"cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:*"
],
"vendor_product": "debian:debian_linux",
"extracted_events": [
{
"range": [
{
"introduced": "10.0"
},
{
"last_affected": "10.0"
},
{
"introduced": "11.0"
},
{
"last_affected": "11.0"
}
],
"source": "CPE_STRING"
}
]
}
]
}
},
"related_cves": [
{
"value": "CVE-2021-22895",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 385484,
"published_at": "2021-06-11T16:15:10.797+00:00"
}