Security advisory
aerospike is an Aerospike add-on module for Node.js. aerospike versions below 2.4.2 download binary resources over HTTP, which leaves the module vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2016-10558
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 04:49 UTC · Revision 1
Source evidence
aerospike is an Aerospike add-on module for Node.js. aerospike versions below 2.4.2 download binary resources over HTTP, which leaves the module vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.
osv:CVE-2016-10558
Complete source record
{
"id": "2cb09a9495abaee6ef6debfb8f2a15b1fb8dc0b644c27c3fabb33da43fd5cada",
"url": "https://osv.dev/vulnerability/CVE-2016-10558",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2016-10558",
"summary": "aerospike is an Aerospike add-on module for Node.js. aerospike versions below 2.4.2 download binary resources over HTTP, which leaves the module vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.",
"evidence": "osv:CVE-2016-10558",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2016-10558",
"aliases": [
"CVE-2016-10558",
"GHSA-v5v3-8jqf-vg27"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/aerospike/aerospike-client-nodejs",
"type": "GIT",
"events": [
{
"introduced": "0"
},
{
"fixed": "ab87bf92ba82ba0e11e88b211bcae5a76c69df8a"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:aerospike:aerospike:*:*:*:*:*:node.js:*:*",
"range": [
{
"introduced": "0"
},
{
"fixed": "2.4.2"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"versions": [
"v2.4.1",
"v2.4.0",
"v2.3.1",
"v2.3.0",
"v2.2.0",
"v2.1.1",
"v2.1.0",
"v2.0.4",
"v2.0.2",
"v2.0.1",
"2.0.0",
"2.0.0-alpha.3",
"2.0.0-alpha.2",
"2.0.0-alpha.1",
"1.0.56",
"1.0.55",
"1.0.54",
"1.0.52",
"1.0.45",
"1.0.44",
"1.0.40",
"1.0.39",
"1.0.36",
"1.0.34",
"1.0.31",
"1.0.30",
"1.0.18",
"1.0.17",
"1.0.16",
"1.0.15",
"1.0.14",
"1.0.13",
"1.0.12",
"1.0.11",
"1.0.10",
"1.0.9",
"1.0.8",
"1.0.7",
"1.0.5",
"1.0.1",
"1.0.0"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2016-10558.json"
}
}
],
"modified": "2026-10-24T10:30:22.543721720Z",
"provider": "osv",
"references": [
"https://nodesecurity.io/advisories/167"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2016-10558",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 430709,
"published_at": "2018-05-29T20:29:00.797+00:00"
}