Skip to content
Heist/ feed
Back to feed
Medium

Docmost has cross-page attachment overwrite via flawed attachmentId overwrite validation

Type: advisorySources: OSV

Docmost is open-source collaborative wiki and documentation software. Starting in version 0.3.0 and prior to version 0.71.0, improper authorization in Docmost allows a low-privileged authenticated user to overwrite another page's attachment within the same workspace by supplying a victim `attachmentId` to `POST /api/files/upload`. This is a remote integrity issue requiring no victim interaction. Version 0.71.0 contains a patch.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2026-34213
Confirmed fixed CVEs
Not specified
Updated in this feed
4 Nov 2026, 02:01 UTC · Revision 1

Source evidence

Docmost has cross-page attachment overwrite via flawed attachmentId overwrite validation

core-osv · Original source

Published 14 Apr 2026, 21:49 UTC

Docmost is open-source collaborative wiki and documentation software. Starting in version 0.3.0 and prior to version 0.71.0, improper authorization in Docmost allows a low-privileged authenticated user to overwrite another page's attachment within the same workspace by supplying a victim `attachmentId` to `POST /api/files/upload`. This is a remote integrity issue requiring no victim interaction. Version 0.71.0 contains a patch.

osv:CVE-2026-34213
Complete source record
{
  "id": "960333505aaf483405247575eb44e76f0d4ada44254bc8683b23483b0bf4b728",
  "url": "https://osv.dev/vulnerability/CVE-2026-34213",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Docmost has cross-page attachment overwrite via flawed attachmentId overwrite validation",
    "summary": "Docmost is open-source collaborative wiki and documentation software. Starting in version 0.3.0 and prior to version 0.71.0, improper authorization in Docmost allows a low-privileged authenticated user to overwrite another page's attachment within the same workspace by supplying a victim `attachmentId` to `POST /api/files/upload`. This is a remote integrity issue requiring no victim interaction. Version 0.71.0 contains a patch.",
    "evidence": "osv:CVE-2026-34213",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2026-34213",
      "aliases": [
        "CVE-2026-34213",
        "GHSA-89fp-2hch-j9gp"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/docmost/docmost",
              "type": "GIT",
              "events": [
                {
                  "introduced": "73ddec4ca7415073d765cc62d100030223936b6c"
                },
                {
                  "fixed": "642024ba9d1afcc7c14ad3c34da8495037faeaf1"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "0.3.0"
                      },
                      {
                        "fixed": "0.71.0"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StringRangeExpression"
                  },
                  {
                    "cpe": "cpe:2.3:a:docmost:docmost:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "0.3.0"
                      },
                      {
                        "fixed": "0.71.0"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v0.70.2",
            "v0.70.1",
            "v0.70.3",
            "v0.70.0",
            "v0.25.3",
            "v0.25.2",
            "v0.25.1",
            "v0.25.0",
            "v0.25.0-beta.1",
            "v0.24.1",
            "v0.24.0",
            "v0.23.2",
            "v0.23.1",
            "v0.23.0",
            "v0.22.2",
            "v0.22.1",
            "v0.22.0",
            "v0.21.0",
            "v0.20.4",
            "v0.20.3",
            "v0.20.2",
            "v0.20.1",
            "v0.20.0",
            "v0.10.2",
            "v0.10.1",
            "v0.10.0",
            "v0.9.0",
            "v0.8.4",
            "v0.8.3",
            "v0.8.2",
            "v0.8.1",
            "v0.8.0",
            "v0.7.0",
            "v0.6.2",
            "v0.6.1",
            "v0.6.0",
            "v0.5.0",
            "v0.4.1",
            "v0.4.0",
            "v0.3.1",
            "v0.3.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-34213.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:32.337562771Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/34xxx/CVE-2026-34213.json",
        "https://github.com/docmost/docmost/security/advisories/GHSA-89fp-2hch-j9gp",
        "https://nvd.nist.gov/vuln/detail/CVE-2026-34213"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-639"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/34xxx/CVE-2026-34213.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2026-34213",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 499528,
  "published_at": "2026-04-14T21:49:55.38+00:00"
}