openssh — security advisory
OpenSSH 7.7 through 7.9 and 8.x before 8.1, when compiled with an experimental key type, has a pre-authentication integer overflow if a client or server is configured to use a crafted XMSS key. This leads to memory corruption and local code execution because of an error in the XMSS key parsing algorithm. NOTE: the XMSS implementation is considered experimental in all released OpenSSH versions, and there is no supported way to enable it when building portable OpenSSH.
- Products
- openssh
- Affected versions
- Not specified
- Fixed versions
- 1:8.1p1-1
- CVEs
- CVE-2019-16905
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 14:28 UTC · Revision 1
Source evidence
OpenSSH 7.7 through 7.9 and 8.x before 8.1, when compiled with an experimental key type, has a pre-authentication integer overflow if a client or server is configured to use a crafted XMSS key. This leads to memory corruption and local code execution because of an error in the XMSS key parsing algorithm. NOTE: the XMSS implementation is considered experimental in all released OpenSSH versions, and there is no supported way to enable it when building portable OpenSSH.
osv:DEBIAN-CVE-2019-16905
openssh
Fixed versions: 1:8.1p1-1
openssh
Fixed versions: 1:8.1p1-1
openssh
Fixed versions: 1:8.1p1-1
Complete source record
{
"id": "c9bedf7c43bfc1315a3f70fdfe31e905d3afeb51a2e1dfe7401935d73c7d1bf2",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2019-16905",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2019-16905",
"summary": "OpenSSH 7.7 through 7.9 and 8.x before 8.1, when compiled with an experimental key type, has a pre-authentication integer overflow if a client or server is configured to use a crafted XMSS key. This leads to memory corruption and local code execution because of an error in the XMSS key parsing algorithm. NOTE: the XMSS implementation is considered experimental in all released OpenSSH versions, and there is no supported way to enable it when building portable OpenSSH.",
"evidence": "osv:DEBIAN-CVE-2019-16905",
"products": [
{
"name": {
"value": "openssh",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1:8.1p1-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "openssh",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1:8.1p1-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "openssh",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1:8.1p1-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2019-16905",
"aliases": [
"DEBIAN-CVE-2019-16905"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1:8.1p1-1"
}
]
}
],
"package": {
"name": "openssh",
"purl": "pkg:deb/debian/openssh?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2019-16905.json"
},
"ecosystem_specific": {
"urgency": "unimportant"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1:8.1p1-1"
}
]
}
],
"package": {
"name": "openssh",
"purl": "pkg:deb/debian/openssh?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2019-16905.json"
},
"ecosystem_specific": {
"urgency": "unimportant"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1:8.1p1-1"
}
]
}
],
"package": {
"name": "openssh",
"purl": "pkg:deb/debian/openssh?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2019-16905.json"
},
"ecosystem_specific": {
"urgency": "unimportant"
}
}
],
"modified": "2026-10-15T07:47:33.155323468Z",
"provider": "osv",
"upstream": [
"CVE-2019-16905"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2019-16905"
]
},
"related_cves": [
{
"value": "CVE-2019-16905",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 322238,
"published_at": "2019-10-09T20:15:23.503+00:00"
}