HighFix available
wolfssl — security advisory
wolfSSL before 5.4.0 allows remote attackers to cause a denial of service via DTLS because a check for return-routability can be skipped.
- Products
- wolfssl
- Affected versions
- Not specified
- Fixed versions
- 5.5.3-1
- CVEs
- CVE-2022-34293
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 14:42 UTC · Revision 1
Source evidence
wolfSSL before 5.4.0 allows remote attackers to cause a denial of service via DTLS because a check for return-routability can be skipped.
osv:DEBIAN-CVE-2022-34293
wolfssl
Fixed versions: 5.5.3-1
wolfssl
Fixed versions: 5.5.3-1
Complete source record
{
"id": "d5c0bc40b1a6639acd48fe3466d567fa43db153c72717f7a2c1a93095223a767",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-34293",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2022-34293",
"summary": "wolfSSL before 5.4.0 allows remote attackers to cause a denial of service via DTLS because a check for return-routability can be skipped.",
"evidence": "osv:DEBIAN-CVE-2022-34293",
"products": [
{
"name": {
"value": "wolfssl",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "5.5.3-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "wolfssl",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "5.5.3-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2022-34293",
"aliases": [
"DEBIAN-CVE-2022-34293"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "5.5.3-1"
}
]
}
],
"package": {
"name": "wolfssl",
"purl": "pkg:deb/debian/wolfssl?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-34293.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "5.5.3-1"
}
]
}
],
"package": {
"name": "wolfssl",
"purl": "pkg:deb/debian/wolfssl?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-34293.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-15T08:01:36.374421091Z",
"provider": "osv",
"upstream": [
"CVE-2022-34293"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2022-34293"
]
},
"related_cves": [
{
"value": "CVE-2022-34293",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 323053,
"published_at": "2022-08-08T16:15:08.39+00:00"
}