Skip to content
Heist/ feed
Back to feed
HighFix available

sudo — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2022-43995

Sudo 1.8.0 through 1.9.12, with the crypt() password backend, contains a plugins/sudoers/auth/passwd.c array-out-of-bounds error that can result in a heap-based buffer over-read. This can be triggered by arbitrary local users with access to Sudo by entering a password of seven characters or fewer. The impact could vary depending on the system libraries, compiler, and processor architecture.

Products
sudo
Affected versions
Not specified
Fixed versions
1.9.12p1-1
CVEs
CVE-2022-43995
Confirmed fixed CVEs
Not specified
Updated in this feed
30 Oct 2026, 15:32 UTC · Revision 1

Source evidence

DEBIAN-CVE-2022-43995

core-osv · Original source

Published 2 Nov 2022, 14:15 UTC

Sudo 1.8.0 through 1.9.12, with the crypt() password backend, contains a plugins/sudoers/auth/passwd.c array-out-of-bounds error that can result in a heap-based buffer over-read. This can be triggered by arbitrary local users with access to Sudo by entering a password of seven characters or fewer. The impact could vary depending on the system libraries, compiler, and processor architecture.

osv:DEBIAN-CVE-2022-43995

sudo

Fixed versions: 1.9.12p1-1

sudo

Fixed versions: 1.9.12p1-1

sudo

Fixed versions: 1.9.12p1-1

Complete source record
{
  "id": "8544266590041224d88315eb37c2a036fef9b27e5ae41d102f2e4e71c61cfddb",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-43995",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2022-43995",
    "summary": "Sudo 1.8.0 through 1.9.12, with the crypt() password backend, contains a plugins/sudoers/auth/passwd.c array-out-of-bounds error that can result in a heap-based buffer over-read. This can be triggered by arbitrary local users with access to Sudo by entering a password of seven characters or fewer. The impact could vary depending on the system libraries, compiler, and processor architecture.",
    "evidence": "osv:DEBIAN-CVE-2022-43995",
    "products": [
      {
        "name": {
          "value": "sudo",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1.9.12p1-1",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "sudo",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1.9.12p1-1",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "sudo",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "1.9.12p1-1",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "high",
    "structured": {
      "id": "DEBIAN-CVE-2022-43995",
      "aliases": [
        "DEBIAN-CVE-2022-43995"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1.9.12p1-1"
                }
              ]
            }
          ],
          "package": {
            "name": "sudo",
            "purl": "pkg:deb/debian/sudo?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-43995.json"
          },
          "ecosystem_specific": {
            "urgency": "unimportant"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1.9.12p1-1"
                }
              ]
            }
          ],
          "package": {
            "name": "sudo",
            "purl": "pkg:deb/debian/sudo?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-43995.json"
          },
          "ecosystem_specific": {
            "urgency": "unimportant"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "1.9.12p1-1"
                }
              ]
            }
          ],
          "package": {
            "name": "sudo",
            "purl": "pkg:deb/debian/sudo?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-43995.json"
          },
          "ecosystem_specific": {
            "urgency": "unimportant"
          }
        }
      ],
      "modified": "2026-10-15T08:03:06.388157971Z",
      "provider": "osv",
      "upstream": [
        "CVE-2022-43995"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2022-43995"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2022-43995",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 325178,
  "published_at": "2022-11-02T14:15:16.187+00:00"
}