Skip to content
Heist/ feed
Back to feed
High

ModSecurity: Unsigned integer underflow in @verifySSN / @verifyCPF / @verifySVNR operators

Type: advisorySources: OSV

ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. From 3.0.0 to before 3.0.15, there is an unhandled exception (std::out_of_range) caused by unsigned integer underflow in libmodsecurity3 if the user (administrator) uses a rule any of @verifySSN, @verifyCPF, or @verifySVNR. This vulnerability is fixed in 3.0.15.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2026-42268
Confirmed fixed CVEs
Not specified
Updated in this feed
3 Nov 2026, 16:30 UTC · Revision 1

Source evidence

ModSecurity: Unsigned integer underflow in @verifySSN / @verifyCPF / @verifySVNR operators

core-osv · Original source

Published 12 May 2026, 21:40 UTC

ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. From 3.0.0 to before 3.0.15, there is an unhandled exception (std::out_of_range) caused by unsigned integer underflow in libmodsecurity3 if the user (administrator) uses a rule any of @verifySSN, @verifyCPF, or @verifySVNR. This vulnerability is fixed in 3.0.15.

osv:CVE-2026-42268
Complete source record
{
  "id": "b0acc7aaceaa8390b921e6403bcb607b5a85a1ee941f2988c4a2cc65e3c2650a",
  "url": "https://osv.dev/vulnerability/CVE-2026-42268",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "ModSecurity: Unsigned integer underflow in @verifySSN / @verifyCPF / @verifySVNR operators",
    "summary": "ModSecurity is an open source, cross platform web application firewall (WAF) engine for Apache, IIS and Nginx. From 3.0.0 to before 3.0.15, there is an unhandled exception (std::out_of_range) caused by unsigned integer underflow in libmodsecurity3 if the user (administrator) uses a rule any of @verifySSN, @verifyCPF, or @verifySVNR. This vulnerability is fixed in 3.0.15.",
    "evidence": "osv:CVE-2026-42268",
    "products": [],
    "severity": "high",
    "structured": {
      "id": "CVE-2026-42268",
      "aliases": [
        "BIT-modsecurity-2026-42268",
        "BIT-modsecurity2-2026-42268",
        "CVE-2026-42268",
        "GHSA-vwr3-7x7g-7p9w"
      ],
      "metrics": [
        {
          "type": "CVSS_V4",
          "score": "CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/owasp-modsecurity/modsecurity",
              "type": "GIT",
              "events": [
                {
                  "introduced": "c1cd668acb820824e791ba802396c60900eae9c1"
                },
                {
                  "fixed": "0fb4aff98b4980cf6426697d5605c424e3d5bb60"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "introduced": "3.0.0"
                      },
                      {
                        "fixed": "3.0.15"
                      }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StringRangeExpression"
                  },
                  {
                    "cpe": "cpe:2.3:a:owasp:modsecurity:*:*:*:*:*:*:*:*",
                    "range": [
                      {
                        "introduced": "3.0.0"
                      },
                      {
                        "fixed": "3.0.15"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v3.0.14",
            "v3.0.13",
            "v3.0.12",
            "v3.0.11",
            "v3.0.10",
            "v3.0.9",
            "v3.0.8",
            "v3.0.7",
            "v3.0.6",
            "v3.0.5",
            "v3.0.4",
            "v3.0.3",
            "v3.0.2",
            "v3.0.1",
            "v3.0.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-42268.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:30.211098705Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/42xxx/CVE-2026-42268.json",
        "https://github.com/owasp-modsecurity/ModSecurity/security/advisories/GHSA-vwr3-7x7g-7p9w",
        "https://nvd.nist.gov/vuln/detail/CVE-2026-42268"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-191",
          "CWE-248"
        ],
        "cna_assigner": "GitHub_M",
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/42xxx/CVE-2026-42268.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2026-42268",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 497404,
  "published_at": "2026-05-12T21:40:19.031+00:00"
}