Skip to content
Heist/ feed
Back to feed
Medium

Simple Lightbox < 2.9.4 - Contributor+ Stored XSS

Type: advisorySources: OSV

The Simple Lightbox WordPress plugin before 2.9.4 does not validate and escape some of its attributes before outputting them back in a page/post, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2025-3516
Confirmed fixed CVEs
Not specified
Updated in this feed
7 Nov 2026, 01:50 UTC · Revision 1

Source evidence

Simple Lightbox < 2.9.4 - Contributor+ Stored XSS

core-osv · Original source

Published 16 May 2025, 06:00 UTC

The Simple Lightbox WordPress plugin before 2.9.4 does not validate and escape some of its attributes before outputting them back in a page/post, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.

osv:CVE-2025-3516
Complete source record
{
  "id": "dec31e79fcb88e7189d4a6792e8314e21161196309fc112711d6b25a0804a39c",
  "url": "https://osv.dev/vulnerability/CVE-2025-3516",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Simple Lightbox < 2.9.4 - Contributor+ Stored XSS",
    "summary": "The Simple Lightbox WordPress plugin before 2.9.4 does not validate and escape some of its attributes before outputting them back in a page/post, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks.",
    "evidence": "osv:CVE-2025-3516",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2025-3516",
      "aliases": [
        "CVE-2025-3516"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:L"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/archetyped/simple-lightbox",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "42f68752ec414ac84d802a72c719264100180513"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:archetyped:simple_lightbox:*:*:*:*:*:wordpress:*:*",
                    "range": [
                      {
                        "introduced": "0"
                      },
                      {
                        "fixed": "2.9.4"
                      }
                    ],
                    "source": "CPE_RANGE"
                  }
                ]
              }
            }
          ],
          "versions": [
            "2.9.3",
            "2.9.2",
            "2.9.1",
            "2.9.0",
            "2.8.1",
            "2.8.0",
            "2.7.1",
            "2.7.0",
            "2.6.0",
            "2.5.3",
            "2.5.1",
            "2.5.0",
            "2.4.0-rc1",
            "2.4.0-b3",
            "2.4.0-b2",
            "2.4.0-b1",
            "2.3.1",
            "2.3.0",
            "2.3.0-b3",
            "2.3.0-b2",
            "2.3.0-b1"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2025-3516.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:48.699727533Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/3xxx/CVE-2025-3516.json",
        "https://nvd.nist.gov/vuln/detail/CVE-2025-3516",
        "https://wpscan.com/vulnerability/336a78cd-297b-4f47-a007-e33eac7f1dad/"
      ],
      "provider_metadata": {
        "cna_assigner": "WPScan",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "fixed": "2.9.4"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "StandardRange"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2025/3xxx/CVE-2025-3516.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2025-3516",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 517120,
  "published_at": "2025-05-16T06:00:04.784+00:00"
}