jq — security advisory
jq is a command-line JSON processor. Prior to 1.8.2, comparing two sufficiently deeply nested arrays with the == operator exhausts the C stack on jq's ordinary command-line surface, resulting in denial of service via stack exhaustion (uncontrolled recursion). The crash occurs in jq's recursive structural comparison code, with the recursion repeating through jvp_array_equal() and jv_equal() in src/jv.c when comparing deeply nested arrays; a nearby sort comparator path through jv_cmp() in src/jv_aux.c overflows the stack at a larger nesting depth from the same missing recursion guard. Anyone running jq comparisons on attacker-controlled deeply nested JSON values, or embedding jq in a context where untrusted data can reach the == comparison path, is affected. This vulnerability is fixed in 1.8.2.
- Products
- jq
- Affected versions
- 1.6-2.1, 1.6-2.1+deb12u1, 1.7.1-6+deb13u1, 1.7.1-6+deb13u2, 1.8.0-1, 1.8.1-1, 1.8.1-2, 1.8.1-3, 1.8.1-4, 1.8.1-5, 1.8.1-6
- Fixed versions
- 1.6-2.1+deb12u2, 1.7.1-6+deb13u3, 1.8.1-7
- CVEs
- CVE-2026-47770
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 12:16 UTC · Revision 2
Source evidence
jq is a command-line JSON processor. Prior to 1.8.2, comparing two sufficiently deeply nested arrays with the == operator exhausts the C stack on jq's ordinary command-line surface, resulting in denial of service via stack exhaustion (uncontrolled recursion). The crash occurs in jq's recursive structural comparison code, with the recursion repeating through jvp_array_equal() and jv_equal() in src/jv.c when comparing deeply nested arrays; a nearby sort comparator path through jv_cmp() in src/jv_aux.c overflows the stack at a larger nesting depth from the same missing recursion guard. Anyone running jq comparisons on attacker-controlled deeply nested JSON values, or embedding jq in a context where untrusted data can reach the == comparison path, is affected. This vulnerability is fixed in 1.8.2.
osv:DEBIAN-CVE-2026-47770
jq
Fixed versions: 1.6-2.1+deb12u2
jq
Fixed versions: 1.7.1-6+deb13u3
jq
Fixed versions: 1.8.1-7
Complete source record
{
"id": "56a37190d66c6fdb46391c5e13451ef56e1beeaebe28b5e58d636695efb92681",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2026-47770",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2026-47770",
"summary": "jq is a command-line JSON processor. Prior to 1.8.2, comparing two sufficiently deeply nested arrays with the == operator exhausts the C stack on jq's ordinary command-line surface, resulting in denial of service via stack exhaustion (uncontrolled recursion). The crash occurs in jq's recursive structural comparison code, with the recursion repeating through jvp_array_equal() and jv_equal() in src/jv.c when comparing deeply nested arrays; a nearby sort comparator path through jv_cmp() in src/jv_aux.c overflows the stack at a larger nesting depth from the same missing recursion guard. Anyone running jq comparisons on attacker-controlled deeply nested JSON values, or embedding jq in a context where untrusted data can reach the == comparison path, is affected. This vulnerability is fixed in 1.8.2.",
"evidence": "osv:DEBIAN-CVE-2026-47770",
"products": [
{
"name": {
"value": "jq",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.6-2.1+deb12u2",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": [
{
"value": "1.6-2.1",
"evidence": "/affected/0/versions"
},
{
"value": "1.6-2.1+deb12u1",
"evidence": "/affected/0/versions"
}
]
},
{
"name": {
"value": "jq",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.7.1-6+deb13u3",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": [
{
"value": "1.7.1-6+deb13u1",
"evidence": "/affected/1/versions"
},
{
"value": "1.7.1-6+deb13u2",
"evidence": "/affected/1/versions"
}
]
},
{
"name": {
"value": "jq",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.8.1-7",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": [
{
"value": "1.8.0-1",
"evidence": "/affected/2/versions"
},
{
"value": "1.8.1-1",
"evidence": "/affected/2/versions"
},
{
"value": "1.8.1-2",
"evidence": "/affected/2/versions"
},
{
"value": "1.8.1-3",
"evidence": "/affected/2/versions"
},
{
"value": "1.8.1-4",
"evidence": "/affected/2/versions"
},
{
"value": "1.8.1-5",
"evidence": "/affected/2/versions"
},
{
"value": "1.8.1-6",
"evidence": "/affected/2/versions"
}
]
}
],
"severity": "medium",
"structured": {
"id": "DEBIAN-CVE-2026-47770",
"aliases": [
"DEBIAN-CVE-2026-47770"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.6-2.1+deb12u2"
}
]
}
],
"package": {
"name": "jq",
"purl": "pkg:deb/debian/jq?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"versions": [
"1.6-2.1",
"1.6-2.1+deb12u1"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-47770.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.7.1-6+deb13u3"
}
]
}
],
"package": {
"name": "jq",
"purl": "pkg:deb/debian/jq?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"versions": [
"1.7.1-6+deb13u1",
"1.7.1-6+deb13u2"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-47770.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.8.1-7"
}
]
}
],
"package": {
"name": "jq",
"purl": "pkg:deb/debian/jq?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"versions": [
"1.8.0-1",
"1.8.1-1",
"1.8.1-2",
"1.8.1-3",
"1.8.1-4",
"1.8.1-5",
"1.8.1-6"
],
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2026-47770.json"
},
"ecosystem_specific": {
"urgency": "not yet assigned"
}
}
],
"modified": "2026-10-26T11:47:29.491968291Z",
"provider": "osv",
"upstream": [
"CVE-2026-47770"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2026-47770"
]
},
"related_cves": [
{
"value": "CVE-2026-47770",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 450755,
"published_at": "2026-06-25T18:16:38.08+00:00"
}