Skip to content
Heist/ feed
Back to feed
Medium

RSSHub Cross-site Scripting vulnerability caused by internal media proxy

Type: advisorySources: OSV

RSSHub is an open source RSS feed generator. Starting in version 1.0.0-master.cbbd829 and prior to version 1.0.0-master.d8ca915, ahen the specially crafted image is supplied to the internal media proxy, it proxies the image without handling XSS vulnerabilities, allowing for the execution of arbitrary JavaScript code. Users who access the deliberately constructed URL are affected. This vulnerability was fixed in version 1.0.0-master.d8ca915. No known workarounds are available.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2024-27926
Confirmed fixed CVEs
Not specified
Updated in this feed
7 Nov 2026, 08:47 UTC · Revision 1

Source evidence

RSSHub Cross-site Scripting vulnerability caused by internal media proxy

core-osv · Original source

Published 6 Mar 2024, 20:36 UTC

RSSHub is an open source RSS feed generator. Starting in version 1.0.0-master.cbbd829 and prior to version 1.0.0-master.d8ca915, ahen the specially crafted image is supplied to the internal media proxy, it proxies the image without handling XSS vulnerabilities, allowing for the execution of arbitrary JavaScript code. Users who access the deliberately constructed URL are affected. This vulnerability was fixed in version 1.0.0-master.d8ca915. No known workarounds are available.

osv:CVE-2024-27926
Complete source record
{
  "id": "98458f7001bdc29444460b8144092184399ee9e86120c16cf17a2198e1d0e718",
  "url": "https://osv.dev/vulnerability/CVE-2024-27926",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "RSSHub Cross-site Scripting vulnerability caused by internal media proxy",
    "summary": "RSSHub is an open source RSS feed generator. Starting in version 1.0.0-master.cbbd829 and prior to version 1.0.0-master.d8ca915, ahen the specially crafted image is supplied to the internal media proxy, it proxies the image without handling XSS vulnerabilities, allowing for the execution of arbitrary JavaScript code. Users who access the deliberately constructed URL are affected. This vulnerability was fixed in version 1.0.0-master.d8ca915. No known workarounds are available.",
    "evidence": "osv:CVE-2024-27926",
    "products": [],
    "severity": "medium",
    "structured": {
      "id": "CVE-2024-27926",
      "aliases": [
        "CVE-2024-27926",
        "GHSA-2wqw-hr4f-xrhh"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/diygod/rsshub",
              "type": "GIT",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "4d3e5d79c1c17837e931b4cd253d2013b487aa87"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "range": [
                      {
                        "fixed": "4d3e5d79c1c17837e931b4cd253d2013b487aa87"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  }
                ]
              }
            }
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-27926.json"
          }
        }
      ],
      "modified": "2026-10-28T02:30:50.360147675Z",
      "provider": "osv",
      "references": [
        "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/27xxx/CVE-2024-27926.json",
        "https://github.com/DIYgod/RSSHub/security/advisories/GHSA-2wqw-hr4f-xrhh",
        "https://nvd.nist.gov/vuln/detail/CVE-2024-27926",
        "https://github.com/DIYgod/RSSHub/commit/4d3e5d79c1c17837e931b4cd253d2013b487aa87"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-79"
        ],
        "cna_assigner": "GitHub_M",
        "unresolved_ranges": [
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "introduced": "1.0.0-master.cbbd829"
                  },
                  {
                    "fixed": "1.0.0-master.d8ca915"
                  }
                ],
                "source": "AFFECTED_FIELD",
                "strategy": "StringRangeExpression"
              }
            ]
          },
          {
            "extracted_events": [
              {
                "range": [
                  {
                    "fixed": "1.0.0-master.d8ca915"
                  },
                  {
                    "fixed": "1.0.0-master.d8ca915"
                  },
                  {
                    "last_affected": "1.0.0-master.cbbd829"
                  }
                ],
                "source": "DESCRIPTION"
              }
            ]
          }
        ],
        "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/27xxx/CVE-2024-27926.json"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2024-27926",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 518797,
  "published_at": "2024-03-06T20:36:04.28+00:00"
}