SpecterOps BloodHound Graph Write Endpoint v2.go NewV2API improper authorization
A weakness has been identified in SpecterOps BloodHound up to 9.5.1. The affected element is the function NewV2API of the file cmd/api/src/api/registration/v2.go of the component Graph Write Endpoint. Executing a manipulation can lead to improper authorization. It is possible to launch the attack remotely. Upgrading to version 9.6.0-rc1, 9.6.0 and 9.7.0-rc3 is sufficient to fix this issue. This patch is called 39d1276a63e95a7713f954dea632a19651d9cebb. You should upgrade the affected component.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2026-85241
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 3 Nov 2026, 07:45 UTC · Revision 1
Source evidence
SpecterOps BloodHound Graph Write Endpoint v2.go NewV2API improper authorization
core-osv · Original sourcePublished 3 Sept 2026, 22:30 UTC
A weakness has been identified in SpecterOps BloodHound up to 9.5.1. The affected element is the function NewV2API of the file cmd/api/src/api/registration/v2.go of the component Graph Write Endpoint. Executing a manipulation can lead to improper authorization. It is possible to launch the attack remotely. Upgrading to version 9.6.0-rc1, 9.6.0 and 9.7.0-rc3 is sufficient to fix this issue. This patch is called 39d1276a63e95a7713f954dea632a19651d9cebb. You should upgrade the affected component.
osv:CVE-2026-85241
Complete source record
{
"id": "a76d2a6088740186daaade8a18532c4d91019d86d9c677487a60235f61a0c50d",
"url": "https://osv.dev/vulnerability/CVE-2026-85241",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "SpecterOps BloodHound Graph Write Endpoint v2.go NewV2API improper authorization",
"summary": "A weakness has been identified in SpecterOps BloodHound up to 9.5.1. The affected element is the function NewV2API of the file cmd/api/src/api/registration/v2.go of the component Graph Write Endpoint. Executing a manipulation can lead to improper authorization. It is possible to launch the attack remotely. Upgrading to version 9.6.0-rc1, 9.6.0 and 9.7.0-rc3 is sufficient to fix this issue. This patch is called 39d1276a63e95a7713f954dea632a19651d9cebb. You should upgrade the affected component.",
"evidence": "osv:CVE-2026-85241",
"products": [],
"severity": "medium",
"structured": {
"id": "CVE-2026-85241",
"aliases": [
"CVE-2026-85241"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/specterops/bloodhound",
"type": "GIT",
"events": [
{
"introduced": "b0345aed8c17e121b5a8412f898b00adfdcdc772"
},
{
"fixed": "39d1276a63e95a7713f954dea632a19651d9cebb"
},
{
"fixed": "89e6d6555a6174d529c74aeb732eb47d762f0c44"
}
],
"database_specific": {
"extracted_events": [
{
"range": [
{
"introduced": "9.0.0"
},
{
"last_affected": "9.0.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"introduced": "9.1.0"
},
{
"last_affected": "9.1.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"introduced": "9.2.2"
},
{
"last_affected": "9.2.2"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"introduced": "9.4.0"
},
{
"last_affected": "9.4.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"introduced": "9.5.0"
},
{
"last_affected": "9.5.0"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"introduced": "9.5.1"
},
{
"last_affected": "9.5.1"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandaloneSingleVersion"
},
{
"range": [
{
"fixed": "39d1276a63e95a7713f954dea632a19651d9cebb"
}
],
"source": "REFERENCES_COMMIT"
},
{
"range": [
{
"fixed": "89e6d6555a6174d529c74aeb732eb47d762f0c44"
}
],
"source": "REFERENCES_TAG",
"original_tag": "v9.6.0-rc1"
}
]
}
}
],
"versions": [
"9.0.0",
"9.1.0",
"9.2.2",
"9.4.0",
"9.5.0",
"9.5.1"
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2026-85241.json"
}
}
],
"modified": "2026-10-28T02:30:26.851312906Z",
"provider": "osv",
"references": [
"https://github.com/SpecterOps/BloodHound/",
"https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/85xxx/CVE-2026-85241.json",
"https://nvd.nist.gov/vuln/detail/CVE-2026-85241",
"https://vuldb.com/cve/CVE-2026-85241",
"https://vuldb.com/submit/894488",
"https://vuldb.com/vuln/398471",
"https://vuldb.com/vuln/398471/cti",
"https://github.com/SpecterOps/BloodHound/commit/39d1276a63e95a7713f954dea632a19651d9cebb",
"https://github.com/SpecterOps/BloodHound/releases/tag/v9.6.0-rc1"
],
"provider_metadata": {
"cwe_ids": [
"CWE-266",
"CWE-285"
],
"cna_assigner": "VulDB",
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2026/85xxx/CVE-2026-85241.json"
}
},
"related_cves": [
{
"value": "CVE-2026-85241",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 493418,
"published_at": "2026-09-03T22:30:14.587+00:00"
}