Skip to content
Heist/ feed
Back to feed
CriticalFix available

Payload: Prototype pollution in Payload Import Export plugin

Type: advisorySources: OSV

### Impact An unauthenticated user could cause unintended application behavior when the Import Export plugin is enabled, allowing an attacker to submit and execute remote code (RCE). Applications that do not use `@payloadcms/plugin-import-export` are not affected. ### Patches Users should upgrade Payload packages to `>= 3.88.0` or `>= 4.0.0-canary.27.` ### Workarounds Upgrading is recommended. Until then, disable the Import Export plugin or restrict access to its endpoints.

Products
@payloadcms/plugin-import-export
Affected versions
Not specified
Fixed versions
3.88.0, 4.0.0-canary.27
CVEs
CVE-2026-105844
Confirmed fixed CVEs
Not specified
Updated in this feed
27 Oct 2026, 12:11 UTC · Revision 1

Source evidence

Payload: Prototype pollution in Payload Import Export plugin

core-osv · Original source

Published 6 Oct 2026, 16:09 UTC

### Impact An unauthenticated user could cause unintended application behavior when the Import Export plugin is enabled, allowing an attacker to submit and execute remote code (RCE). Applications that do not use `@payloadcms/plugin-import-export` are not affected. ### Patches Users should upgrade Payload packages to `>= 3.88.0` or `>= 4.0.0-canary.27.` ### Workarounds Upgrading is recommended. Until then, disable the Import Export plugin or restrict access to its endpoints.

osv:GHSA-qf28-8hc6-vwrp

@payloadcms/plugin-import-export

Fixed versions: 3.88.0

@payloadcms/plugin-import-export

Fixed versions: 4.0.0-canary.27

Complete source record
{
  "id": "5479de654b2ff78e2bd060a6ad4177f558055a14fbe76c86e2ee6ad3508db00c",
  "url": "https://osv.dev/vulnerability/GHSA-qf28-8hc6-vwrp",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "Payload: Prototype pollution in Payload Import Export plugin",
    "summary": "### Impact An unauthenticated user could cause unintended application behavior when the Import Export plugin is enabled, allowing an attacker to submit and execute remote code (RCE). Applications that do not use `@payloadcms/plugin-import-export` are not affected. ### Patches Users should upgrade Payload packages to `>= 3.88.0` or `>= 4.0.0-canary.27.` ### Workarounds Upgrading is recommended. Until then, disable the Import Export plugin or restrict access to its endpoints.",
    "evidence": "osv:GHSA-qf28-8hc6-vwrp",
    "products": [
      {
        "name": {
          "value": "@payloadcms/plugin-import-export",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "3.88.0",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "@payloadcms/plugin-import-export",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "4.0.0-canary.27",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "critical",
    "structured": {
      "id": "GHSA-qf28-8hc6-vwrp",
      "aliases": [
        "CVE-2026-105844",
        "GHSA-qf28-8hc6-vwrp"
      ],
      "metrics": [
        {
          "type": "CVSS_V4",
          "score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "SEMVER",
              "events": [
                {
                  "introduced": "3.0.0"
                },
                {
                  "fixed": "3.88.0"
                }
              ]
            }
          ],
          "package": {
            "name": "@payloadcms/plugin-import-export",
            "purl": "pkg:npm/%40payloadcms/plugin-import-export",
            "ecosystem": "npm"
          },
          "database_specific": {
            "source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/10/GHSA-qf28-8hc6-vwrp/GHSA-qf28-8hc6-vwrp.json"
          }
        },
        {
          "ranges": [
            {
              "type": "SEMVER",
              "events": [
                {
                  "introduced": "4.0.0-canary.0"
                },
                {
                  "fixed": "4.0.0-canary.27"
                }
              ]
            }
          ],
          "package": {
            "name": "@payloadcms/plugin-import-export",
            "purl": "pkg:npm/%40payloadcms/plugin-import-export",
            "ecosystem": "npm"
          },
          "database_specific": {
            "source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/10/GHSA-qf28-8hc6-vwrp/GHSA-qf28-8hc6-vwrp.json"
          }
        }
      ],
      "modified": "2026-10-06T16:15:04.821648224Z",
      "provider": "osv",
      "references": [
        "https://github.com/payloadcms/payload/security/advisories/GHSA-qf28-8hc6-vwrp",
        "https://github.com/payloadcms/payload/commit/a742140ab4fca3160f7f83e9e7d996552ffc3b5a",
        "https://github.com/payloadcms/payload",
        "https://github.com/payloadcms/payload/releases/tag/v3.88.0"
      ],
      "provider_metadata": {
        "cwe_ids": [
          "CWE-1321"
        ],
        "severity": "CRITICAL",
        "github_reviewed": true,
        "nvd_published_at": null,
        "github_reviewed_at": "2026-10-06T16:09:23Z"
      }
    },
    "related_cves": [
      {
        "value": "CVE-2026-105844",
        "evidence": "/aliases"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/database_specific/severity"
  },
  "source_id": "core-osv",
  "document_id": 89305,
  "published_at": "2026-10-06T16:09:23+00:00"
}