@payloadcms/plugin-multi-tenant has a cross-tenant create issue
### Impact An authenticated user limited to one tenant could create a record in another tenant. This requires the multi-tenant plugin with at least one tenant-enabled collection. Reads and direct edits to an existing target-tenant document were not bypassed. You are affected if: - You are using @payloadcms/plugin-multi-tenant ### Patches Users should upgrade Payload packages to `>= 3.90.0` or `>= 4.0.0-canary.34`. ### Workarounds You can add access control with `accessResultOverride` on the multi-tenant collection config to ensure a user has access to the tenant before creating.
- Products
- @payloadcms/plugin-multi-tenant
- Affected versions
- Not specified
- Fixed versions
- 3.90.0, 4.0.0-canary.34
- CVEs
- CVE-2026-105864
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 28 Oct 2026, 08:48 UTC · Revision 1
Source evidence
@payloadcms/plugin-multi-tenant has a cross-tenant create issue
core-osv · Original sourcePublished 7 Oct 2026, 20:29 UTC
### Impact An authenticated user limited to one tenant could create a record in another tenant. This requires the multi-tenant plugin with at least one tenant-enabled collection. Reads and direct edits to an existing target-tenant document were not bypassed. You are affected if: - You are using @payloadcms/plugin-multi-tenant ### Patches Users should upgrade Payload packages to `>= 3.90.0` or `>= 4.0.0-canary.34`. ### Workarounds You can add access control with `accessResultOverride` on the multi-tenant collection config to ensure a user has access to the tenant before creating.
osv:GHSA-xhm9-gwgw-3q2q
@payloadcms/plugin-multi-tenant
Fixed versions: 3.90.0
@payloadcms/plugin-multi-tenant
Fixed versions: 4.0.0-canary.34
Complete source record
{
"id": "3cf435bb4944684a929fc0a8b661f812007b758b9736a9a4bca5054fc5191e46",
"url": "https://osv.dev/vulnerability/GHSA-xhm9-gwgw-3q2q",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "@payloadcms/plugin-multi-tenant has a cross-tenant create issue",
"summary": "### Impact An authenticated user limited to one tenant could create a record in another tenant. This requires the multi-tenant plugin with at least one tenant-enabled collection. Reads and direct edits to an existing target-tenant document were not bypassed. You are affected if: - You are using @payloadcms/plugin-multi-tenant ### Patches Users should upgrade Payload packages to `>= 3.90.0` or `>= 4.0.0-canary.34`. ### Workarounds You can add access control with `accessResultOverride` on the multi-tenant collection config to ensure a user has access to the tenant before creating.",
"evidence": "osv:GHSA-xhm9-gwgw-3q2q",
"products": [
{
"name": {
"value": "@payloadcms/plugin-multi-tenant",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "3.90.0",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "@payloadcms/plugin-multi-tenant",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "4.0.0-canary.34",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
}
],
"severity": "medium",
"structured": {
"id": "GHSA-xhm9-gwgw-3q2q",
"aliases": [
"CVE-2026-105864",
"GHSA-xhm9-gwgw-3q2q"
],
"metrics": [
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N"
}
],
"affected": [
{
"ranges": [
{
"type": "SEMVER",
"events": [
{
"introduced": "0"
},
{
"fixed": "3.90.0"
}
]
}
],
"package": {
"name": "@payloadcms/plugin-multi-tenant",
"purl": "pkg:npm/%40payloadcms/plugin-multi-tenant",
"ecosystem": "npm"
},
"database_specific": {
"source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/10/GHSA-xhm9-gwgw-3q2q/GHSA-xhm9-gwgw-3q2q.json"
}
},
{
"ranges": [
{
"type": "SEMVER",
"events": [
{
"introduced": "4.0.0-canary.0"
},
{
"fixed": "4.0.0-canary.34"
}
]
}
],
"package": {
"name": "@payloadcms/plugin-multi-tenant",
"purl": "pkg:npm/%40payloadcms/plugin-multi-tenant",
"ecosystem": "npm"
},
"database_specific": {
"source": "https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/10/GHSA-xhm9-gwgw-3q2q/GHSA-xhm9-gwgw-3q2q.json"
}
}
],
"modified": "2026-10-07T20:45:07.236890143Z",
"provider": "osv",
"references": [
"https://github.com/payloadcms/payload/security/advisories/GHSA-xhm9-gwgw-3q2q",
"https://nvd.nist.gov/vuln/detail/CVE-2026-105864",
"https://github.com/payloadcms/payload/commit/b8fc06a18afb6974dc07f95ac1e541c716e5926b",
"https://github.com/payloadcms/payload",
"https://github.com/payloadcms/payload/releases/tag/v3.90.0"
],
"provider_metadata": {
"cwe_ids": [
"CWE-863"
],
"severity": "MODERATE",
"github_reviewed": true,
"nvd_published_at": "2026-10-06T17:17:22Z",
"github_reviewed_at": "2026-10-07T20:29:27Z"
}
},
"related_cves": [
{
"value": "CVE-2026-105864",
"evidence": "/aliases"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 97275,
"published_at": "2026-10-07T20:29:27+00:00"
}