Skip to content
Heist/ feed
Back to feed
HighFix available

lua5.4 — security advisory

Type: advisorySources: OSVAdvisory ID: DEBIAN-CVE-2022-33099

An issue in the component luaG_runerror of Lua v5.4.4 and below leads to a heap-buffer overflow when a recursive error occurs.

Products
lua5.4
Affected versions
Not specified
Fixed versions
5.4.4-3
CVEs
CVE-2022-33099
Confirmed fixed CVEs
Not specified
Updated in this feed
30 Oct 2026, 14:44 UTC · Revision 1

Source evidence

DEBIAN-CVE-2022-33099

core-osv · Original source

Published 1 Jul 2022, 12:15 UTC

An issue in the component luaG_runerror of Lua v5.4.4 and below leads to a heap-buffer overflow when a recursive error occurs.

osv:DEBIAN-CVE-2022-33099

lua5.4

Fixed versions: 5.4.4-3

lua5.4

Fixed versions: 5.4.4-3

lua5.4

Fixed versions: 5.4.4-3

Complete source record
{
  "id": "8bb2db658f4ab1ad281571fbc3d0e49782ffbc74a79fa7a2b5c3e9bae569d496",
  "url": "https://osv.dev/vulnerability/DEBIAN-CVE-2022-33099",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "DEBIAN-CVE-2022-33099",
    "summary": "An issue in the component luaG_runerror of Lua v5.4.4 and below leads to a heap-buffer overflow when a recursive error occurs.",
    "evidence": "osv:DEBIAN-CVE-2022-33099",
    "products": [
      {
        "name": {
          "value": "lua5.4",
          "evidence": "/affected/0/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "5.4.4-3",
            "evidence": "/affected/0/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "lua5.4",
          "evidence": "/affected/1/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "5.4.4-3",
            "evidence": "/affected/1/ranges"
          }
        ],
        "affected_versions": []
      },
      {
        "name": {
          "value": "lua5.4",
          "evidence": "/affected/2/package/name"
        },
        "prerequisites": [],
        "fixed_versions": [
          {
            "value": "5.4.4-3",
            "evidence": "/affected/2/ranges"
          }
        ],
        "affected_versions": []
      }
    ],
    "severity": "high",
    "structured": {
      "id": "DEBIAN-CVE-2022-33099",
      "aliases": [
        "DEBIAN-CVE-2022-33099"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "5.4.4-3"
                }
              ]
            }
          ],
          "package": {
            "name": "lua5.4",
            "purl": "pkg:deb/debian/lua5.4?arch=source&distro=bookworm",
            "ecosystem": "Debian:12"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-33099.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "5.4.4-3"
                }
              ]
            }
          ],
          "package": {
            "name": "lua5.4",
            "purl": "pkg:deb/debian/lua5.4?arch=source&distro=trixie",
            "ecosystem": "Debian:13"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-33099.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        },
        {
          "ranges": [
            {
              "type": "ECOSYSTEM",
              "events": [
                {
                  "introduced": "0"
                },
                {
                  "fixed": "5.4.4-3"
                }
              ]
            }
          ],
          "package": {
            "name": "lua5.4",
            "purl": "pkg:deb/debian/lua5.4?arch=source&distro=forky",
            "ecosystem": "Debian:14"
          },
          "database_specific": {
            "source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2022-33099.json"
          },
          "ecosystem_specific": {
            "urgency": "not yet assigned"
          }
        }
      ],
      "modified": "2026-10-15T08:01:55.152081734Z",
      "provider": "osv",
      "upstream": [
        "CVE-2022-33099"
      ],
      "references": [
        "https://security-tracker.debian.org/tracker/CVE-2022-33099"
      ]
    },
    "related_cves": [
      {
        "value": "CVE-2022-33099",
        "evidence": "/upstream"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 323201,
  "published_at": "2022-07-01T12:15:08.173+00:00"
}