HighFix available
lz4 — security advisory
LZ4 before 1.9.2 has a heap-based buffer overflow in LZ4_write32 (related to LZ4_compress_destSize), affecting applications that call LZ4_compress_fast with a large input. (This issue can also lead to data corruption.) NOTE: the vendor states "only a few specific / uncommon usages of the API are at risk."
- Products
- lz4
- Affected versions
- Not specified
- Fixed versions
- 1.9.2-1
- CVEs
- CVE-2019-17543
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 30 Oct 2026, 14:29 UTC · Revision 1
Source evidence
LZ4 before 1.9.2 has a heap-based buffer overflow in LZ4_write32 (related to LZ4_compress_destSize), affecting applications that call LZ4_compress_fast with a large input. (This issue can also lead to data corruption.) NOTE: the vendor states "only a few specific / uncommon usages of the API are at risk."
osv:DEBIAN-CVE-2019-17543
lz4
Fixed versions: 1.9.2-1
lz4
Fixed versions: 1.9.2-1
lz4
Fixed versions: 1.9.2-1
Complete source record
{
"id": "28b252800357b006e780f1a5b83044cd04d686cbcdf3502047f4b3d53600ce5b",
"url": "https://osv.dev/vulnerability/DEBIAN-CVE-2019-17543",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "DEBIAN-CVE-2019-17543",
"summary": "LZ4 before 1.9.2 has a heap-based buffer overflow in LZ4_write32 (related to LZ4_compress_destSize), affecting applications that call LZ4_compress_fast with a large input. (This issue can also lead to data corruption.) NOTE: the vendor states \"only a few specific / uncommon usages of the API are at risk.\"",
"evidence": "osv:DEBIAN-CVE-2019-17543",
"products": [
{
"name": {
"value": "lz4",
"evidence": "/affected/0/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.9.2-1",
"evidence": "/affected/0/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "lz4",
"evidence": "/affected/1/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.9.2-1",
"evidence": "/affected/1/ranges"
}
],
"affected_versions": []
},
{
"name": {
"value": "lz4",
"evidence": "/affected/2/package/name"
},
"prerequisites": [],
"fixed_versions": [
{
"value": "1.9.2-1",
"evidence": "/affected/2/ranges"
}
],
"affected_versions": []
}
],
"severity": "high",
"structured": {
"id": "DEBIAN-CVE-2019-17543",
"aliases": [
"DEBIAN-CVE-2019-17543"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H"
}
],
"affected": [
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.9.2-1"
}
]
}
],
"package": {
"name": "lz4",
"purl": "pkg:deb/debian/lz4?arch=source&distro=bookworm",
"ecosystem": "Debian:12"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2019-17543.json"
},
"ecosystem_specific": {
"urgency": "low"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.9.2-1"
}
]
}
],
"package": {
"name": "lz4",
"purl": "pkg:deb/debian/lz4?arch=source&distro=trixie",
"ecosystem": "Debian:13"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2019-17543.json"
},
"ecosystem_specific": {
"urgency": "low"
}
},
{
"ranges": [
{
"type": "ECOSYSTEM",
"events": [
{
"introduced": "0"
},
{
"fixed": "1.9.2-1"
}
]
}
],
"package": {
"name": "lz4",
"purl": "pkg:deb/debian/lz4?arch=source&distro=forky",
"ecosystem": "Debian:14"
},
"database_specific": {
"source": "https://storage.googleapis.com/debian-osv/debian-cve-osv/DEBIAN-CVE-2019-17543.json"
},
"ecosystem_specific": {
"urgency": "low"
}
}
],
"modified": "2026-10-15T07:47:35.642188461Z",
"provider": "osv",
"upstream": [
"CVE-2019-17543"
],
"references": [
"https://security-tracker.debian.org/tracker/CVE-2019-17543"
]
},
"related_cves": [
{
"value": "CVE-2019-17543",
"evidence": "/upstream"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 322278,
"published_at": "2019-10-14T02:15:10.873+00:00"
}