Skip to content
Heist/ feed
Back to feed
Critical

Security advisory

Type: advisorySources: OSVCVE: CVE-2021-21304

Dynamoose is an open-source modeling tool for Amazon's DynamoDB. In Dynamoose from version 2.0.0 and before version 2.7.0 there was a prototype pollution vulnerability in the internal utility method "lib/utils/object/set.ts". This method is used throughout the codebase for various operations throughout Dynamoose. We have not seen any evidence of this vulnerability being exploited. There is no evidence this vulnerability impacts versions 1.x.x since the vulnerable method was added as part of the v2 rewrite. This vulnerability also impacts v2.x.x beta/alpha versions. Version 2.7.0 includes a patch for this vulnerability.

Products
Not specified
Affected versions
Not specified
Fixed versions
Not specified
CVEs
CVE-2021-21304
Confirmed fixed CVEs
Not specified
Updated in this feed
31 Oct 2026, 11:32 UTC · Revision 1

Source evidence

CVE-2021-21304

core-osv · Original source

Published 8 Feb 2021, 18:15 UTC

Dynamoose is an open-source modeling tool for Amazon's DynamoDB. In Dynamoose from version 2.0.0 and before version 2.7.0 there was a prototype pollution vulnerability in the internal utility method "lib/utils/object/set.ts". This method is used throughout the codebase for various operations throughout Dynamoose. We have not seen any evidence of this vulnerability being exploited. There is no evidence this vulnerability impacts versions 1.x.x since the vulnerable method was added as part of the v2 rewrite. This vulnerability also impacts v2.x.x beta/alpha versions. Version 2.7.0 includes a patch for this vulnerability.

osv:CVE-2021-21304
Complete source record
{
  "id": "271c01ac3efde9dbd09ded51af6bda8bed873b4b05035d1da9862ae49817814b",
  "url": "https://osv.dev/vulnerability/CVE-2021-21304",
  "method": "structured",
  "payload": {
    "kind": "advisory",
    "title": "CVE-2021-21304",
    "summary": "Dynamoose is an open-source modeling tool for Amazon's DynamoDB. In Dynamoose from version 2.0.0 and before version 2.7.0 there was a prototype pollution vulnerability in the internal utility method \"lib/utils/object/set.ts\". This method is used throughout the codebase for various operations throughout Dynamoose. We have not seen any evidence of this vulnerability being exploited. There is no evidence this vulnerability impacts versions 1.x.x since the vulnerable method was added as part of the v2 rewrite. This vulnerability also impacts v2.x.x beta/alpha versions. Version 2.7.0 includes a patch for this vulnerability.",
    "evidence": "osv:CVE-2021-21304",
    "products": [],
    "severity": "critical",
    "structured": {
      "id": "CVE-2021-21304",
      "aliases": [
        "CVE-2021-21304",
        "GHSA-rrqm-p222-8ph2"
      ],
      "metrics": [
        {
          "type": "CVSS_V3",
          "score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H"
        }
      ],
      "affected": [
        {
          "ranges": [
            {
              "repo": "https://github.com/dynamoose/dynamoose",
              "type": "GIT",
              "events": [
                {
                  "introduced": "147b90f20b08de33c1694928424fe67cb1e7ba81"
                },
                {
                  "fixed": "e2ec6eaf726cce741da101883617bbfd2c21dd98"
                },
                {
                  "fixed": "324c62b4709204955931a187362f8999805b1d8e"
                }
              ],
              "database_specific": {
                "extracted_events": [
                  {
                    "cpe": "cpe:2.3:a:dynamoosejs:dynamoose:*:*:*:*:*:node.js:*:*",
                    "range": [
                      {
                        "introduced": "2.0.0"
                      },
                      {
                        "fixed": "2.7.0"
                      }
                    ],
                    "source": "CPE_RANGE"
                  },
                  {
                    "range": [
                      {
                        "fixed": "324c62b4709204955931a187362f8999805b1d8e"
                      }
                    ],
                    "source": "REFERENCES_COMMIT"
                  },
                  {
                    "range": [
                      {
                        "fixed": "e2ec6eaf726cce741da101883617bbfd2c21dd98"
                      }
                    ],
                    "source": "REFERENCES_TAG",
                    "original_tag": "v2.7.0"
                  }
                ]
              }
            }
          ],
          "versions": [
            "v2.6.0",
            "v2.5.0",
            "v2.4.1",
            "v2.4.0",
            "v2.3.0",
            "v2.3.0-beta.1",
            "v2.2.1",
            "v2.2.0",
            "v2.1.3",
            "v2.1.2",
            "v2.1.1",
            "v2.1.0",
            "v2.0.0"
          ],
          "database_specific": {
            "source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2021-21304.json"
          }
        }
      ],
      "modified": "2026-10-20T10:54:28.502008761Z",
      "provider": "osv",
      "references": [
        "https://github.com/dynamoose/dynamoose/releases/tag/v2.7.0",
        "https://www.npmjs.com/package/dynamoose",
        "https://github.com/dynamoose/dynamoose/commit/324c62b4709204955931a187362f8999805b1d8e",
        "https://github.com/dynamoose/dynamoose/security/advisories/GHSA-rrqm-p222-8ph2"
      ],
      "provider_metadata": {}
    },
    "related_cves": [
      {
        "value": "CVE-2021-21304",
        "evidence": "/id"
      }
    ],
    "security_relevant": true,
    "severity_evidence": "/severity/0/score"
  },
  "source_id": "core-osv",
  "document_id": 385417,
  "published_at": "2021-02-08T18:15:13.537+00:00"
}