High
Security advisory
A vulnerability was found in gnutls versions from 3.5.8 before 3.6.7. A memory corruption (double free) vulnerability in the certificate verification API. Any client or server application that verifies X.509 certificates with GnuTLS 3.5.8 or later is affected.
- Products
- Not specified
- Affected versions
- Not specified
- Fixed versions
- Not specified
- CVEs
- CVE-2019-3829
- Confirmed fixed CVEs
- Not specified
- Updated in this feed
- 1 Nov 2026, 08:45 UTC · Revision 1
Source evidence
A vulnerability was found in gnutls versions from 3.5.8 before 3.6.7. A memory corruption (double free) vulnerability in the certificate verification API. Any client or server application that verifies X.509 certificates with GnuTLS 3.5.8 or later is affected.
osv:CVE-2019-3829
Complete source record
{
"id": "fc6308aa1fb0199ccce7c9c89e67f4fdcb362d588268e7071aa04b94e48d8a67",
"url": "https://osv.dev/vulnerability/CVE-2019-3829",
"method": "structured",
"payload": {
"kind": "advisory",
"title": "CVE-2019-3829",
"summary": "A vulnerability was found in gnutls versions from 3.5.8 before 3.6.7. A memory corruption (double free) vulnerability in the certificate verification API. Any client or server application that verifies X.509 certificates with GnuTLS 3.5.8 or later is affected.",
"evidence": "osv:CVE-2019-3829",
"products": [],
"severity": "high",
"structured": {
"id": "CVE-2019-3829",
"aliases": [
"CVE-2019-3829"
],
"metrics": [
{
"type": "CVSS_V3",
"score": "CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H"
}
],
"affected": [
{
"ranges": [
{
"repo": "https://github.com/gnutls/gnutls",
"type": "GIT",
"events": [
{
"introduced": "7ac0ccdd207376964738aa674904de3d1a9660c2"
},
{
"fixed": "2a40a3d90df001c520ab5f25f97608f5eb3c489e"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:gnu:gnutls:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "3.5.8"
},
{
"fixed": "3.6.7"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-3829.json"
}
},
{
"ranges": [
{
"repo": "https://gitlab.com/gnutls/gnutls",
"type": "GIT",
"events": [
{
"introduced": "7ac0ccdd207376964738aa674904de3d1a9660c2"
},
{
"fixed": "2a40a3d90df001c520ab5f25f97608f5eb3c489e"
}
],
"database_specific": {
"extracted_events": [
{
"cpe": "cpe:2.3:a:gnu:gnutls:*:*:*:*:*:*:*:*",
"range": [
{
"introduced": "3.5.8"
},
{
"fixed": "3.6.7"
}
],
"source": "CPE_RANGE"
}
]
}
}
],
"database_specific": {
"source": "https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2019-3829.json"
}
}
],
"modified": "2026-10-24T10:50:04.346053553Z",
"provider": "osv",
"references": [
"https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/A3ETBUFBB4G7AITAOUYPGXVMBGVXKUAN/",
"https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/L7TJIBRJWGWSH6XIO2MXIQ3W6ES4R6I4/",
"https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WRSOL66LHP4SD3Y2ECJDOGT4K663ECDU/",
"https://usn.ubuntu.com/3999-1/",
"https://access.redhat.com/errata/RHSA-2019:3600",
"https://security.gentoo.org/glsa/201904-14",
"https://security.netapp.com/advisory/ntap-20190619-0004/",
"https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-3829",
"https://gitlab.com/gnutls/gnutls/issues/694",
"https://www.gnutls.org/security-new.html#GNUTLS-SA-2019-03-27"
],
"provider_metadata": {}
},
"related_cves": [
{
"value": "CVE-2019-3829",
"evidence": "/id"
}
],
"security_relevant": true,
"severity_evidence": "/severity/0/score"
},
"source_id": "core-osv",
"document_id": 441925,
"published_at": "2019-03-27T18:29:00.693+00:00"
}